summary refs log tree commit diff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2018-08-26 15:28:00 +0200
committerJulien Lepiller <julien@lepiller.eu>2018-09-01 23:08:06 +0200
commit83d9f672212907bb0c683f0be428c1d847bf6001 (patch)
treeefb494cd6e9f0172f896d98bdee0e835145b83dd /gnu/packages/ruby.scm
parent3224a5a84a261fcc8a6972ace1cbd0018371d34f (diff)
downloadguix-83d9f672212907bb0c683f0be428c1d847bf6001.tar.gz
gnu: Add ruby-cane.
* gnu/packages/ruby.scm (ruby-cane): New variable.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index c3ce6ca39a..b7a55fa31f 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -5424,3 +5424,22 @@ interface.  It allows Jekyll to rebuild your site when a file changes.")
 (to use all CPUs) or Threads(to speedup blocking operations).  It is best
 suited for map-reduce or e.g. parallel downloads/uploads.")
     (license license:expat)))
+
+(define-public ruby-cane
+  (package
+    (name "ruby-cane")
+    (version "3.0.0")
+    (source (origin
+              (method url-fetch)
+              (uri (rubygems-uri "cane" version))
+              (sha256
+               (base32
+                "0yf5za3l7lhrqa3g56sah73wh33lbxy5y3cb7ij0a2bp1b4kwhih"))))
+    (build-system ruby-build-system)
+    (arguments `(#:tests? #f)); No rakefile
+    (home-page "https://github.com/square/cane")
+    (propagated-inputs
+     `(("ruby-parallel" ,ruby-parallel)))
+    (synopsis "Code quality threshold checking")
+    (description "Cane fails your build if code quality thresholds are not met.")
+    (license license:asl2.0)))