summary refs log tree commit diff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorGiacomo Leidi <goodoldpaul@autistici.org>2021-01-04 01:32:10 +0100
committerChristopher Baines <mail@cbaines.net>2021-02-05 19:37:28 +0000
commitdbe02ce50fb595b32c83770d2c15e80607cd5f5a (patch)
treebbf8409093f36bb55d35c7ca360fb72e546c7d9e /gnu/packages/ruby.scm
parent838347207cdd96de1ad0127aaf4b2c378c7c2148 (diff)
downloadguix-dbe02ce50fb595b32c83770d2c15e80607cd5f5a.tar.gz
gnu: Add ruby-yell.
* gnu/packages/ruby.scm (ruby-yell): New variable.

Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index b811cbd2c4..04d4d2f334 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -11764,3 +11764,30 @@ defined in @file{.travis.yml} on your local machine, using @code{rvm},
 you the speed and portability of libgit2 with the beauty of the Ruby
 language.")
     (license license:expat)))
+
+(define-public ruby-yell
+  (package
+    (name "ruby-yell")
+    (version "2.2.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (rubygems-uri "yell" version))
+       (sha256
+        (base32
+         "1g16kcdhdfvczn7x81jiq6afg3bdxmb73skqjyjlkp5nqcy6y5hx"))))
+    (build-system ruby-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda _
+             (invoke "rake" "examples")))))) ; there is no test target.
+    (synopsis
+     "Extensible logging library for Ruby")
+    (description
+     "Yell is a comprehensive logging replacement for Ruby.  It defines
+multiple adapters, various log level combinations and message formatting
+options.")
+    (home-page "https://github.com/rudionrails/yell")
+    (license license:expat)))