summary refs log tree commit diff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-05-11 10:50:30 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-05-11 13:51:40 +0300
commitee559bca27b09fe81f15bf5c9c55ad698ac3926b (patch)
tree76343301ce3b6e366b4826d9991a6db7db7d0757 /gnu/packages/ruby.scm
parente54d18895565561767ef24544aa88a5e89b6507b (diff)
downloadguix-ee559bca27b09fe81f15bf5c9c55ad698ac3926b.tar.gz
gnu: Add ruby-hkdf.
* gnu/packages/ruby.scm (ruby-hkdf): New variable.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index dcf5eb33ad..77cfdca84d 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -2835,6 +2835,33 @@ high-level toolkit for building cryptographic systems and protocols.")
     (home-page "https://github.com/crypto-rb/rbnacl")
     (license license:expat)))
 
+(define-public ruby-hkdf
+  (package
+    (name "ruby-hkdf")
+    (version "1.0.0")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/jtdowney/hkdf")
+               (commit (string-append "v" version))))
+        (file-name (git-file-name name version))
+        (sha256
+         (base32
+          "1xqwdmxfnhagivwgb5v9ilwpb4jxlsqwj7pnj43d65zzg5m8p9r5"))))
+    (build-system ruby-build-system)
+    (arguments
+     `(#:test-target "default"))
+    (native-inputs
+     `(("ruby-rspec" ,ruby-rspec)))
+    (synopsis "HMAC-based Key Derivation Function")
+    (description
+     "This package provides a Ruby implementation of RFC5869: @acronym{HKDF,
+HMAC-based Extract-and-Expand Key Derivation Function}.  The goal of HKDF is to
+take some source key material and generate suitable cryptographic keys from it.")
+    (home-page "https://github.com/jtdowney/hkdf")
+    (license license:expat)))
+
 (define-public ruby-nenv
   (package
     (name "ruby-nenv")