summary refs log tree commit diff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2017-03-02 18:35:04 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2017-03-03 00:59:30 +0100
commit6f23e2fb023c921d03be1f3aef0e1f305ae63764 (patch)
treeb719b97da7904553ecdec581a3dcbce1d0be933e /gnu/packages/ruby.scm
parent9baab9aeeda394408290613c597bff1d96004dfb (diff)
downloadguix-6f23e2fb023c921d03be1f3aef0e1f305ae63764.tar.gz
gnu: ruby-arel: Remove duplicate definition.
* gnu/packages/ruby.scm (ruby-arel): Remove shadowed 6.0.0 version.
[description]: Use the older description & expand some acronyms.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm25
1 files changed, 3 insertions, 22 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 972bd230d2..73eefe8dde 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -1020,26 +1020,6 @@ features.")
     (home-page "https://github.com/chneukirchen/bacon")
     (license license:expat)))
 
-(define-public ruby-arel
-  (package
-    (name "ruby-arel")
-    (version "6.0.0")
-    (source (origin
-              (method url-fetch)
-              (uri (rubygems-uri "arel" version))
-              (sha256
-               (base32
-                "18wnfnzr2i5p3fygsddjbi1cimws6823nbk8drxidmnj8jz7h0ar"))))
-    (build-system ruby-build-system)
-    (arguments
-     '(#:tests? #f)) ; no test suite
-    (synopsis "SQL AST manager for Ruby")
-    (description "Arel is a SQL AST manager for Ruby.  It simplifies the
-generation of complex SQL queries and adapts to various relational database
-implementations.")
-    (home-page "https://github.com/rails/arel")
-    (license license:expat)))
-
 (define-public ruby-connection-pool
   (package
     (name "ruby-connection-pool")
@@ -1854,8 +1834,9 @@ net/http library.")
     (arguments '(#:tests? #f)) ; no tests
     (home-page "https://github.com/rails/arel")
     (synopsis "SQL AST manager for Ruby")
-    (description "Arel is a SQL AST manager for Ruby.  It simplifies the
-generation of complex SQL queries and is compatible with various RDBMSes.")
+    (description "Arel is an SQL @dfn{Abstract Syntax Tree} (AST) manager for
+Ruby.  It simplifies the generation of complex SQL queries and adapts to
+various relational database implementations.")
     (license license:expat)))
 
 (define-public ruby-minitar