summary refs log tree commit diff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorStephen Paul Weber <singpolyma@singpolyma.net>2021-10-06 12:55:56 -0500
committerLudovic Courtès <ludo@gnu.org>2021-10-26 12:46:28 +0200
commitf8e260e5a2be2d2961bfdf7ad9b5b8da546c9f74 (patch)
tree67b6db25ff5111f3ded019e441e164d84d63ca5c /gnu/packages/ruby.scm
parent409f538d651a7ba26a41f714915e6b7d59e0a82f (diff)
downloadguix-f8e260e5a2be2d2961bfdf7ad9b5b8da546c9f74.tar.gz
gnu: ruby-eventmachine: Add openssl input.
While EventMachine will build without openssl present, attempting to use it to
make any TLS-secured connections will crash at runtime, which is not very
useful.  This allows the build system to find and link OpenSSL and thus TLS will
work at runtime.

* gnu/packages/ruby.scm (ruby-eventmachine): Add openssl input.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm2
1 files changed, 2 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index e9db2cfe31..4a791ebfb5 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -8722,6 +8722,8 @@ application.")
     (build-system ruby-build-system)
     (arguments
      '(#:tests? #f))               ; test suite tries to connect to google.com
+    (inputs
+     `(("openssl" ,openssl)))
     (native-inputs
      `(("ruby-rake-compiler" ,ruby-rake-compiler)))
     (synopsis "Single-threaded network event framework for Ruby")