summary refs log tree commit diff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2018-08-26 13:50:52 +0200
committerJulien Lepiller <julien@lepiller.eu>2018-09-01 23:07:54 +0200
commit6456beef016fea4189b24a5f960ce8e98cd245cc (patch)
treef87013e23118fed28e37ee5c64e8a47aeb7c07c6 /gnu/packages/ruby.scm
parentddc3a66798919afe98173dbd176ce818c57949af (diff)
downloadguix-6456beef016fea4189b24a5f960ce8e98cd245cc.tar.gz
gnu: Add ruby-sass-spec.
* gnu/packages/ruby.scm (ruby-sass-spec): New variable.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 0f2b66139f..c644ba75bd 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -5303,3 +5303,29 @@ about the changes.")
     (description "Diffy provides a convenient way to generate a diff from two
 strings or files.")
     (license license:expat)))
+
+(define-public ruby-sass-spec
+  (package
+    (name "ruby-sass-spec")
+    (version "3.5.4")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://github.com/sass/sass-spec/archive/v"
+                                  version ".tar.gz"))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "0nx8lp7c9qa58w489crgqa3c489xsyarn1a8h4np9mwwfqm1h3rr"))))
+    (build-system ruby-build-system)
+    (propagated-inputs
+     `(("ruby-command-line-reporter-3" ,ruby-command-line-reporter-3)
+       ("ruby-diffy" ,ruby-diffy)
+       ("ruby-terminfo" ,ruby-terminfo)))
+    (arguments
+     ;; No Rakefile
+     `(#:tests? #f))
+    (home-page "https://github.com/sass/sass-spec")
+    (synopsis "Test suite for Sass")
+    (description "Sass Spec is a test suite for Sass.  Test cases are all in
+the @file{spec} directory.")
+    (license license:expat)))