summary refs log tree commit diff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-09-16 10:58:49 +0200
committerDavid Thompson <dthompson2@worcester.edu>2015-09-19 08:43:23 -0400
commitec79018e6831babef249ab883e9f9a71bebe1193 (patch)
tree18c3eb19e3bd982f57d0097a832337565f7e4ccf /gnu/packages/ruby.scm
parent6aaa815e9fae8fccb98c243936210c17cd9609ed (diff)
downloadguix-ec79018e6831babef249ab883e9f9a71bebe1193.tar.gz
gnu: Add ruby-lumberjack.
* gnu/packages/ruby.scm (ruby-lumberjack): New variable.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 9c081624b6..6aaa5dd5ec 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -529,6 +529,27 @@ interfaces.")
     (home-page "http://whatisthor.com/")
     (license license:expat)))
 
+(define-public ruby-lumberjack
+  (package
+    (name "ruby-lumberjack")
+    (version "1.0.9")
+    (source (origin
+              (method url-fetch)
+              (uri (rubygems-uri "lumberjack" version))
+              (sha256
+               (base32
+                "162frm2bwy58pj8ccsdqa4a6i0csrhb9h5l3inhkl1ivgfc8814l"))))
+    (build-system ruby-build-system)
+    (native-inputs
+     `(("ruby-rspec" ,ruby-rspec)))
+    (synopsis "Logging utility library for Ruby")
+    (description "Lumberjack is a simple logging utility that can be a drop in
+replacement for Logger or ActiveSupport::BufferedLogger.  It provides support
+for automatically rolling log files even with multiple processes writing the
+same log file.")
+    (home-page "http://github.com/bdurand/lumberjack")
+    (license license:expat)))
+
 (define-public ruby-useragent
   (package
     (name "ruby-useragent")