summary refs log tree commit diff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2018-08-26 15:46:24 +0200
committerJulien Lepiller <julien@lepiller.eu>2018-09-01 23:08:29 +0200
commit461fb8598efc319a61d3be0996a4f7d402839539 (patch)
treec9aa92be4ce492349fa62f5cd0f9cd7b3ba9d578 /gnu/packages/ruby.scm
parentabbe629c6a25bea320e49163fff71d33521bb127 (diff)
downloadguix-461fb8598efc319a61d3be0996a4f7d402839539.tar.gz
gnu: Add ruby-pdf-inspector.
* gnu/packages/ruby.scm (ruby-pdf-inspector): New variable.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 86b00ef8ae..1ea41109cc 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -5495,3 +5495,24 @@ custom checks.  This gem provides a set of additional checks.")
 much as possible to the PDF specification from Adobe.  It provides programmatic
 access to the contents of a PDF file with a high degree of flexibility.")
     (license license:gpl3+)))
+
+(define-public ruby-pdf-inspector
+  (package
+    (name "ruby-pdf-inspector")
+    (version "1.3.0")
+    (source (origin
+              (method url-fetch)
+              (uri (rubygems-uri "pdf-inspector" version))
+              (sha256
+               (base32
+                "1g853az4xzgqxr5xiwhb76g4sqmjg4s79mm35mp676zjsrwpa47w"))))
+    (build-system ruby-build-system)
+    (propagated-inputs
+     `(("ruby-pdf-reader" ,ruby-pdf-reader)))
+    (arguments `(#:tests? #f)); No rakefile
+    (home-page "https://github.com/prawnpdf/pdf-inspector")
+    (synopsis "Analysis classes for inspecting PDF output")
+    (description "This library provides a number of PDF::Reader based tools for
+use in testing PDF output.  Presently, the primary purpose of this tool is to
+support the tests found in Prawn, a pure Ruby PDF generation library.")
+    (license license:gpl3+)))