summary refs log tree commit diff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-07-17 17:23:38 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-07-17 23:01:35 -0400
commit479c032495b8c872dc4fb5348702a6d4fa07ca8c (patch)
tree889df002d06c60520dff3ac577e90a4c32d1b2d8 /gnu/packages/ruby.scm
parent9c5a7d0012944809128eca76938e8eb573abc979 (diff)
downloadguix-479c032495b8c872dc4fb5348702a6d4fa07ca8c.tar.gz
gnu: ruby-yard: Make the package reproducible.
* gnu/packages/ruby.scm (ruby-yard)[phases]: Add a 'do-not-set-date-in-gemspec
phase.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index e03edfc747..99ef4fbd6b 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -8098,7 +8098,15 @@ A modified copy of yajl is used, and included in the package.")
     (arguments
      ;; Note: Tests are willfully disabled to alleviate dependency cycle
      ;; problems.
-     `(#:tests? #f))
+     `(#:tests? #f
+       #:phases (modify-phases %standard-phases
+                  (add-after 'unpack 'do-not-set-date-in-gemspec
+                    ;; Fix a reproducibility issue (see:
+                    ;; https://github.com/lsegal/yard/issues/1343).
+                    (lambda _
+                      (substitute* "yard.gemspec"
+                        ((".*s\\.date.*") ""))
+                      #t)))))
     (synopsis "Documentation generation tool for Ruby")
     (description "YARD is a documentation generation tool for the Ruby
 programming language.  It enables the user to generate consistent, usable