summary refs log tree commit diff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-11-19 20:18:54 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-11-19 20:48:26 +0200
commit8ed4c468ab611409902c00bdf7c21fdb8d312928 (patch)
tree44b127b886142ff98ce54d2bbcbfb922d85563d9 /gnu/packages/ruby.scm
parent2c2b07c1a349a2c500a9076c1b7abad07b8add88 (diff)
downloadguix-8ed4c468ab611409902c00bdf7c21fdb8d312928.tar.gz
gnu: Don't append '.git' to GitHub uris.
* gnu/packages/admin.scm (nmrpflash)[source]: Remove '.git' from URI.
* gnu/packages/aidc.scm (zxing-cpp),
* gnu/packages/assembly.scm (mbuild),
* gnu/packages/audio.scm (opensles, wildmidi, tinyalsa),
* gnu/packages/browser-extensions.scm (ublock-origin-chromium),
* gnu/packages/check.scm (mutest),
* gnu/packages/compression.scm (unshield),
* gnu/packages/coq.scm (subset),
* gnu/packages/dictionaries.scm (translate-shell),
* gnu/packages/disk.scm (memkind),
* gnu/packages/documentation.scm (latex2html),
* gnu/packages/emacs-xyz.scm (emacs-chronometrist,
  emacs-flycheck-ledger, emacs-counsel-notmuch, emacs-spaceline,
  emacs-org-generate),
* gnu/packages/embedded.scm (ebusd, ebusd-configuration),
* gnu/packages/enchant.scm (nuspell),
* gnu/packages/fontutils.scm (woff2),
* gnu/packages/geo.scm (memphis),
* gnu/packages/gimp.scm (mrg),
* gnu/packages/gnome-xyz.scm (gnome-shell-extension-appindicator),
* gnu/packages/gnome.scm (parlatype),
* gnu/packages/golang.scm (go-github-com-tv42-httpunix,
  go-github-com-ayufan-golang-kardianos-service),
* gnu/packages/graphics.scm (eglexternalplatform, egl-wayland, mmm,
  directfb, flux),
* gnu/packages/gstreamer.scm (openni2, ccextractor, libvisual,
  graphene),
* gnu/packages/guile-xyz.scm (guile-srfi-180, guile-torrent),
* gnu/packages/image.scm (openjpeg-data),
* gnu/packages/java.scm (javacc),
* gnu/packages/language.scm (liblouis, liblouisutdml),
* gnu/packages/linux.scm (pamela, ttyebus),
* gnu/packages/lxqt.scm (lxqt-connman-applet),
* gnu/packages/mail.scm (libetpan),
* gnu/packages/man.scm (ronn),
* gnu/packages/music.scm (tascam-gtk, artyfx),
* gnu/packages/networking.scm (srt, lksctp-tools, nng, nanomsg),
* gnu/packages/python-crypto.scm (pure-python-otr),
* gnu/packages/qt.scm (qtspell),
* gnu/packages/raspberry-pi.scm (raspi-gpio, raspi-open-firmware),
* gnu/packages/rdp.scm (freerdp),
* gnu/packages/ruby.scm (ruby-prawn-templates, ruby-treetop, ruby-gimme,
  ruby-standard, ruby-rubocop-ast, ruby-rexml, ruby-range-compressor,
  ruby-regexp-property-values, ruby-regexp-parser, ruby-rubocop,
  ruby-pdf-reader, ruby-pdf-inspector, ruby-prawn),
* gnu/packages/syncthing.scm (syncthing-gtk),
* gnu/packages/video.scm (svt-hevc, mediasdk, libvideogfx, libde265,
  tslib),
* gnu/packages/xml.scm (libxmlb, libxmlplusplus)[source]: Same.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm30
1 files changed, 15 insertions, 15 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index b34a33a528..2753403834 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -1349,7 +1349,7 @@ Prawn module.")
      (origin
        (method git-fetch)
        (uri (git-reference
-             (url "https://github.com/prawnpdf/prawn-templates.git")
+             (url "https://github.com/prawnpdf/prawn-templates")
              (commit version)))
        (file-name (git-file-name name version))
        (sha256
@@ -1411,7 +1411,7 @@ loader for the file type associated with a filename extension, and it augments
      (origin
        (method git-fetch)               ;no test suite in distributed gem
        (uri (git-reference
-             (url "https://github.com/cjheath/treetop.git")
+             (url "https://github.com/cjheath/treetop")
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
@@ -1474,7 +1474,7 @@ for performance optimizations in Ruby code.")
        (origin
          (method git-fetch)
          (uri (git-reference
-               (url "https://github.com/searls/gimme.git")
+               (url "https://github.com/searls/gimme")
                (commit commit)))
          (file-name (git-file-name name version))
          (sha256
@@ -1535,7 +1535,7 @@ only what they care about.")
      (origin
        (method git-fetch)               ;no test suite in distributed gem
        (uri (git-reference
-             (url "https://github.com/testdouble/standard.git")
+             (url "https://github.com/testdouble/standard")
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
@@ -1587,7 +1587,7 @@ to save time in the following ways:
      (origin
        (method git-fetch)
        (uri (git-reference
-             (url "https://github.com/wvanbergen/chunky_png.git")
+             (url "https://github.com/wvanbergen/chunky_png")
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
@@ -1705,7 +1705,7 @@ web pages.")
        (origin
          (method git-fetch)      ;no test suite in the distributed gem
          (uri (git-reference
-               (url "https://github.com/asciidoctor/asciidoctor-pdf.git")
+               (url "https://github.com/asciidoctor/asciidoctor-pdf")
                (commit commit)))
          (file-name (git-file-name name version))
          (sha256
@@ -6825,7 +6825,7 @@ inspired by the Sinatra microframework style of specifying actions:
      (origin
        (method git-fetch)               ;no test suite in distributed gem
        (uri (git-reference
-             (url "https://github.com/rubocop-hq/rubocop-ast.git")
+             (url "https://github.com/rubocop-hq/rubocop-ast")
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
@@ -6869,7 +6869,7 @@ by RuboCop to deal with Ruby's Abstract Syntax Tree (AST), in particular:
      (origin
        (method git-fetch)               ;no tests in distributed gem
        (uri (git-reference
-             (url "https://github.com/ruby/rexml.git")
+             (url "https://github.com/ruby/rexml")
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
@@ -6920,7 +6920,7 @@ better performance than @code{Regexp} and @code{String} methods from the
       (origin
         (method git-fetch)
         (uri (git-reference
-              (url "https://github.com/janosch-x/range_compressor.git")
+              (url "https://github.com/janosch-x/range_compressor")
               (commit (string-append "v" version))))
         (file-name (git-file-name name version))
         (sha256
@@ -6953,7 +6953,7 @@ following: @code{[1, 2, 3, 4, 6, 8, 9, 10]} into @code{[1..4, 6..6, 8..10]}.")
      (origin
        (method git-fetch)
        (uri (git-reference              ;no test suite in distributed gem
-             (url "https://github.com/jaynetics/regexp_property_values.git")
+             (url "https://github.com/jaynetics/regexp_property_values")
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
@@ -6984,7 +6984,7 @@ they match.")
      (origin
        (method git-fetch)               ;bin/test missing from gem
        (uri (git-reference
-             (url "https://github.com/ammar/regexp_parser.git")
+             (url "https://github.com/ammar/regexp_parser")
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
@@ -7057,7 +7057,7 @@ run.")
      (origin
        (method git-fetch)               ;no tests in distributed gem
        (uri (git-reference
-             (url "https://github.com/rubocop-hq/rubocop.git")
+             (url "https://github.com/rubocop-hq/rubocop")
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
@@ -10537,7 +10537,7 @@ custom checks.  This gem provides a set of additional checks.")
     (source (origin
               (method git-fetch)        ;no test in distributed gem archive
               (uri (git-reference
-                    (url "https://github.com/yob/pdf-reader.git")
+                    (url "https://github.com/yob/pdf-reader")
                     (commit (string-append "v" version))))
               (file-name (git-file-name name version))
               (sha256
@@ -10577,7 +10577,7 @@ access to the contents of a PDF file with a high degree of flexibility.")
       (source (origin
                 (method git-fetch)
                 (uri (git-reference
-                      (url "https://github.com/prawnpdf/pdf-inspector.git")
+                      (url "https://github.com/prawnpdf/pdf-inspector")
                       (commit commit)))
                 (file-name (git-file-name name version))
                 (sha256
@@ -10640,7 +10640,7 @@ functionality from Prawn.")
       (source (origin
                 (method git-fetch)
                 (uri (git-reference
-                      (url "https://github.com/prawnpdf/prawn.git")
+                      (url "https://github.com/prawnpdf/prawn")
                       (commit commit)))
                 (file-name (git-file-name name version))
                 (sha256