summary refs log tree commit diff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-12-28 22:48:02 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-12-28 22:55:06 +0200
commit11d1b31807f283cbb93609853c6132e26a9eb6b8 (patch)
tree7f882d78725a83ff202d107c671a70143ccce1bf /gnu/packages/ruby.scm
parentb872b47bf1283824205609939faa14c3c5a8a9d8 (diff)
downloadguix-11d1b31807f283cbb93609853c6132e26a9eb6b8.tar.gz
gnu: ruby-ae: Don't use unstable tarball.
* gnu/packages/ruby.scm (ruby-ae)[source]: Download using git-fetch.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 0fcb8aead8..0d64e05494 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -6802,15 +6802,15 @@ and locking between worker processes.")
     (version "1.8.2")
     (source
      (origin
-       (method url-fetch)
+       (method git-fetch)
        ;; Fetch from github so tests are included.
-       (uri (string-append
-             "https://github.com/rubyworks/ae/archive/"
-             version ".tar.gz"))
-       (file-name (string-append name "-" version ".tar.gz"))
+       (uri (git-reference
+              (url "https://github.com/rubyworks/ae")
+              (commit version)))
+       (file-name (git-file-name name version))
        (sha256
         (base32
-         "147jmkx54x7asy2d8m4dyrhhf4hdx4galpnhwzai030y3cdsfrrl"))))
+         "11299jj5ma8mi7b4majkyjy70y6zlqpgl8aql1c5lvfjavlpwmlp"))))
     (build-system ruby-build-system)
     (arguments
      `(#:phases
@@ -6836,7 +6836,7 @@ and locking between worker processes.")
     (description
      "Assertive Expressive (AE) is an assertions library specifically designed
 for reuse by other test frameworks.")
-    (home-page "https://rubyworks.github.io/ae")
+    (home-page "https://rubyworks.github.io/ae/")
     (license license:bsd-2)))
 
 (define-public ruby-lemon