summary refs log tree commit diff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-09-12 13:14:05 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-09-12 14:04:56 +0300
commit90f297e4a0a5db525aeb4b17939b7ee4ea7ea433 (patch)
treefc07275d6e00145aa5aed92b074eee06edf27ddc /gnu/packages/ruby.scm
parentcc182dc438a33c6a4832a059b13b5a3ac2d9a27c (diff)
downloadguix-90f297e4a0a5db525aeb4b17939b7ee4ea7ea433.tar.gz
gnu: Add ruby-sync.
* gnu/packages/ruby.scm (ruby-sync): New variable.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index e9b17c56cd..1adc780e81 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -6510,6 +6510,24 @@ acceptable elements, attributes, and CSS properties, Sanitize will remove all
 unacceptable HTML and/or CSS from a string.")
     (license license:expat)))
 
+(define-public ruby-sync
+  (package
+    (name "ruby-sync")
+    (version "0.5.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (rubygems-uri "sync" version))
+        (sha256
+         (base32
+          "1z9qlq4icyiv3hz1znvsq1wz2ccqjb1zwd6gkvnwg6n50z65d0v6"))))
+    (build-system ruby-build-system)
+    (synopsis "Ruby module with a two-phase lock and counter")
+    (description "This package provides a Ruby module that provides a two-phase
+lock with a counter.")
+    (home-page "https://github.com/ruby/sync")
+    (license license:bsd-2)))
+
 (define-public ruby-oj
   (package
     (name "ruby-oj")