summary refs log tree commit diff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-12-30 16:20:38 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-12-30 20:05:14 +0200
commitf3fd70c00e242ecc5c59323f4d7ebe3fcaa9ec4d (patch)
treefa86c405156bde054b014bb6e5d5416dd80703c2 /gnu/packages/ruby.scm
parentbb1e7ed066e97fff06fd10a70be1a582daa97217 (diff)
downloadguix-f3fd70c00e242ecc5c59323f4d7ebe3fcaa9ec4d.tar.gz
gnu: ruby-yard: Don't use unstable tarball.
* gnu/packages/ruby.scm (ruby-yard)[source]: Download using git-fetch.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index a82e39b796..ad675dc488 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -5753,14 +5753,15 @@ A modified copy of yajl is used, and included in the package.")
     (version "0.9.16")
     (source
      (origin
-       (method url-fetch)
+       (method git-fetch)
        ;; Tests do not pass if we build from the distributed gem.
-       (uri (string-append "https://github.com/lsegal/yard/archive/v"
-                           version ".tar.gz"))
-       (file-name (string-append name "-" version ".tar.gz"))
+       (uri (git-reference
+              (url "https://github.com/lsegal/yard")
+              (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
        (sha256
         (base32
-         "0sqpbayy9sb406jh0zqg6qha1xds863qz9531dh6vp58hc00clfq"))))
+         "0a4r1pfs0ms4vlccsf1x2jckx35lqm8b8lh6rdjxqfr5fia5izpf"))))
     (build-system ruby-build-system)
     (arguments
      `(#:phases