summary refs log tree commit diff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-02-17 12:06:08 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-02-17 16:16:36 +0200
commitf7bd9d235eb7d6841ced42e406b896a7384ba7fe (patch)
tree63a8fa37a0d0e29eed183bd659106c5b2041fdac /gnu/packages/ruby.scm
parent6e3a85192ca48a749858c8c7f128c5ec59c2ff89 (diff)
downloadguix-f7bd9d235eb7d6841ced42e406b896a7384ba7fe.tar.gz
gnu: ruby-hashdiff: Update to 1.0.1.
* gnu/packages/ruby.scm (ruby-hashdiff): Update to 1.0.1.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 5c7f1f9aea..28ba7b403e 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -3092,20 +3092,19 @@ immutable queue or stack).")
 (define-public ruby-hashdiff
   (package
     (name "ruby-hashdiff")
-    (version "0.3.8")
+    (version "1.0.1")
     (source
      (origin
        (method url-fetch)
        (uri (rubygems-uri "hashdiff" version))
        (sha256
         (base32
-         "19ykg5pax8798nh1yv71adkx0zzs7gn2rxjj86v7nsw0jba5lask"))))
+         "1nynpl0xbj0nphqx1qlmyggq58ms1phf5i03hk64wcc0a17x1m1c"))))
     (build-system ruby-build-system)
     (arguments
      '(#:phases
        (modify-phases %standard-phases
-         ;; Run tests directly via rspec to avoid Rake issue:
-         ;; NoMethodError: undefined method `last_comment'
+         ;; Run tests directly via rspec to avoid depending on rubocop.
          (replace 'check
            (lambda* (#:key tests? #:allow-other-keys)
              (when tests?