summary refs log tree commit diff
path: root/gnu/packages/rust-apps.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-06-19 11:48:13 +0300
committerEfraim Flashner <efraim@flashner.co.il>2024-07-19 00:47:12 +0300
commit04c704285ea143a1e8646a02e49433f1c953c171 (patch)
tree4c76858337138fa22755323e528edb4c76a97509 /gnu/packages/rust-apps.scm
parentcc164f92dbd8e61e3b56f27019efc58cdd52b936 (diff)
downloadguix-04c704285ea143a1e8646a02e49433f1c953c171.tar.gz
gnu: nsncd: Remove duplicate definition.
* gnu/packages/rust-apps.scm (nsncd): Remove variable.
* gnu/packages/nss.scm (nsncd)[arguments]: Don't install the sources.

Change-Id: I6e95f1b38cdf541a1b341ac9e55bf33ee4bbf098
Diffstat (limited to 'gnu/packages/rust-apps.scm')
-rw-r--r--gnu/packages/rust-apps.scm45
1 files changed, 0 insertions, 45 deletions
diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
index 04f88e769d..d22cf2a98c 100644
--- a/gnu/packages/rust-apps.scm
+++ b/gnu/packages/rust-apps.scm
@@ -1512,51 +1512,6 @@ is being designed to work with Podman but is also applicable for other OCI
 container management applications.")
     (license license:asl2.0)))
 
-(define-public nsncd
-  (package
-    (name "nsncd")
-    (version "1.4.1")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-              (url "https://github.com/twosigma/nsncd")
-              (commit (string-append "v" version))))
-       (file-name (string-append name "-" version ".tar.gz"))
-       (sha256
-        (base32 "03z0fkdp959laa21839y6wz00rg25zvxvr14i1ailj7nkwhysdcx"))
-       (modules '((guix build utils)))
-       (snippet
-        '(begin (substitute* (find-files "." "^Cargo\\.toml$")
-                  (("\"~([[:digit:]]+(\\.[[:digit:]]+)*)" _ version)
-                   (string-append "\"^" version)))))))
-    (build-system cargo-build-system)
-    (arguments
-     (list
-      #:cargo-inputs `(("rust-anyhow" ,rust-anyhow-1)
-                       ("rust-atoi" ,rust-atoi-0.4)
-                       ("rust-slog" ,rust-slog-2)
-                       ("rust-slog-async" ,rust-slog-async-2)
-                       ("rust-slog-term" ,rust-slog-term-2)
-                       ("rust-crossbeam-channel" ,rust-crossbeam-channel-0.5)
-                       ("rust-nix" ,rust-nix-0.21)
-                       ("rust-num-derive" ,rust-num-derive-0.3)
-                       ("rust-num-traits" ,rust-num-traits-0.2)
-                       ("rust-sd-notify" ,rust-sd-notify-0.3)
-                       ("rust-once-cell" ,rust-once-cell-1)
-                       ("rust-static-assertions" ,rust-static-assertions-1))
-      #:cargo-development-inputs `(("rust-criterion" ,rust-criterion-0.3)
-                                   ("rust-temp-env" ,rust-temp-env-0.3))
-      #:install-source? #f))
-    (home-page "https://github.com/twosigma/nsncd")
-    (synopsis "Name service non-caching daemon")
-    (description
-     "Nsncd implements the @acronym{NSCD, name-service caching daemon} protocol
-to provide out-of-process NSS lookups but does not implement caching.  It is
-designed to provide high-performance NSS lookups for programs that are not using
-the system libc, while providing semantics as if NSCD were not being used.")
-    (license license:asl2.0)))
-
 (define-public ripgrep
   (package
     (name "ripgrep")