summary refs log tree commit diff
path: root/gnu/packages/rust.scm
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2018-04-15 10:16:41 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2018-04-16 19:58:05 +0200
commitaf4ea9c5cbeb6fe9c3c694d97db07c335c2e51c9 (patch)
tree97954d81302870c7ac1e778771a02c9da15d0939 /gnu/packages/rust.scm
parenta92bf11c49e83d67b331526a8b752bb4ab85b2aa (diff)
downloadguix-af4ea9c5cbeb6fe9c3c694d97db07c335c2e51c9.tar.gz
gnu: rust: Don't #ignore the same test twice.
* gnu/packages/rust.scm (rust-1.19)[arguments]<#:phases>[patch-tests]:
Don't #ignore the same test twice.
Diffstat (limited to 'gnu/packages/rust.scm')
-rw-r--r--gnu/packages/rust.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
index df5d803b6b..8c5abfcbae 100644
--- a/gnu/packages/rust.scm
+++ b/gnu/packages/rust.scm
@@ -186,7 +186,9 @@ in turn be used to build the final Rust.")
                   "#[ignore]\nfn connect_timeout_unroutable"))
                ;; <https://lists.gnu.org/archive/html/guix-devel/2017-06/msg00222.html>
                (substitute* "src/libstd/sys/unix/process/process_common.rs"
-                 (("fn test_process_mask") "#[ignore]\nfn test_process_mask"))
+                (("#\\[cfg_attr\\(target_arch = \"arm\", ignore\\)\\]
+    fn test_process_mask") "#[ignore]
+    fn test_process_mask"))
                ;; Our ld-wrapper cannot process non-UTF8 bytes in LIBRARY_PATH.
                ;; <https://lists.gnu.org/archive/html/guix-devel/2017-06/msg00193.html>
                (delete-file-recursively "src/test/run-make/linker-output-non-utf8")