summary refs log tree commit diff
path: root/gnu/packages/rust.scm
diff options
context:
space:
mode:
authorIvan Petkov <ivanppetkov@gmail.com>2019-01-27 22:50:46 -0800
committerDanny Milosavljevic <dannym@scratchpost.org>2019-02-14 17:56:30 +0100
commit0e9811f4a3a30c3496b17be78635b32bb0318835 (patch)
tree6743473c1dee36333917ff01b81640b15f7138ad /gnu/packages/rust.scm
parent03d373202347617056ef103d356575d068123db8 (diff)
downloadguix-0e9811f4a3a30c3496b17be78635b32bb0318835.tar.gz
gnu: rust: Update to 1.29.2.
* gnu/packages/rust.scm (rust): Rename to...
(rust-1.28): ...this.
(rust): New variable.
Diffstat (limited to 'gnu/packages/rust.scm')
-rw-r--r--gnu/packages/rust.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
index 501736d898..1796899730 100644
--- a/gnu/packages/rust.scm
+++ b/gnu/packages/rust.scm
@@ -749,7 +749,7 @@ jemalloc = \"" jemalloc "/lib/libjemalloc_pic.a" "\"
                    (("fn thin_lto_works") "#[ignore]\nfn thin_lto_works"))
                  #t)))))))))
 
-(define-public rust
+(define-public rust-1.28
   (let ((base-rust
          (rust-bootstrapped-package rust-1.27 "1.28.0"
                                     "11k4rn77bca2rikykkk9fmprrgjswd4x4kaq7fia08vgkir82nhx"
@@ -782,3 +782,13 @@ jemalloc = \"" jemalloc "/lib/libjemalloc_pic.a" "\"
                  #t))
              ;; The thinlto test should pass with llvm 6.
              (delete 'disable-thinlto-test))))))))
+
+(define-public rust
+  (let ((base-rust
+         (rust-bootstrapped-package rust-1.28 "1.29.2"
+                                    "1jb787080z754caa2w3w1amsygs4qlzj9rs1vy64firfmabfg22h"
+                                    #:patches
+                                    '("rust-1.25-accept-more-detailed-gdb-lines.patch"
+                                      "rust-reproducible-builds.patch"))))
+    (package
+      (inherit base-rust))))