summary refs log tree commit diff
path: root/gnu/packages/sagemath.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2024-01-24 12:35:02 +0100
committerAndreas Enge <andreas@enge.fr>2024-01-26 10:09:35 +0100
commit619417ab232094ae4fd5396139289983b7a0d22f (patch)
tree6d374c920656c1a41f347beefd4dc59878227018 /gnu/packages/sagemath.scm
parent25690a7ce1411795e51759f7087cbead8779915a (diff)
downloadguix-619417ab232094ae4fd5396139289983b7a0d22f.tar.gz
gnu: pynac: Remove package.
The package was integrated into the Sagemath source code in 2021.

* gnu/packages/sagemath.scm (pynac): Remove variable.

Change-Id: I5c6a90ed1747852d0dc4e73b79ce9daa34d876c7
Diffstat (limited to 'gnu/packages/sagemath.scm')
-rw-r--r--gnu/packages/sagemath.scm29
1 files changed, 1 insertions, 28 deletions
diff --git a/gnu/packages/sagemath.scm b/gnu/packages/sagemath.scm
index 242f890c0c..8d5d04ee93 100644
--- a/gnu/packages/sagemath.scm
+++ b/gnu/packages/sagemath.scm
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2019, 2024 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2019 Andreas Enge <andreas@enge.fr>
 ;;; Copyright © 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
 ;;; Copyright © 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
@@ -170,33 +170,6 @@ represented as strings.")
     (license license:public-domain)
     (home-page "https://github.com/miguelmarco/libhomfly")))
 
-(define-public pynac
-  (package
-    (name "pynac")
-    (version "0.7.29")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-              (url "https://github.com/pynac/pynac/")
-              (commit (string-append "pynac-" version))))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32 "1h2b85rmmrsjnqk8z5d811r1lc0h64g7dyk7gfbwyapdcmx7pi51"))))
-    (build-system gnu-build-system)
-    (native-inputs
-     (list autoconf automake libtool pkg-config))
-    (inputs
-     (list flint gmp python singular))
-    (synopsis "Sage fork of GiNaC")
-    (description "Pynac is a derivative of the C++ library GiNaC, which
-allows manipulation of symbolic expressions.  It currently provides the
-backend for symbolic expressions in Sage.  The main difference between
-Pynac and GiNaC is that Pynac relies on Sage to provide the operations
-on numerical types, while GiNaC depends on CLN for this purpose.")
-    (license license:gpl2+)
-    (home-page "http://pynac.org/")))
-
 ;; Sage has become upstream of the following package.
 (define-public zn-poly
   (package