summary refs log tree commit diff
path: root/gnu/packages/sagemath.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2019-01-31 14:55:22 +0100
committerAndreas Enge <andreas@enge.fr>2019-01-31 14:58:47 +0100
commitadba64662cb9db3c587e4b146ff31a1dbbc9f265 (patch)
tree73a0dfaa302bf075e721193c31f1fa6138f2f9c9 /gnu/packages/sagemath.scm
parent11d19ca236c62ffdbb98a3a3580caf09cc37b6de (diff)
downloadguix-adba64662cb9db3c587e4b146ff31a1dbbc9f265.tar.gz
gnu: Add python-cypari2 and python2-cypari2.
* gnu/packages/sagemath.scm: New file.
* gnu/local.mk (GNU_SYSTEM_MODULES): Register new module.
Diffstat (limited to 'gnu/packages/sagemath.scm')
-rw-r--r--gnu/packages/sagemath.scm60
1 files changed, 60 insertions, 0 deletions
diff --git a/gnu/packages/sagemath.scm b/gnu/packages/sagemath.scm
new file mode 100644
index 0000000000..dd8c062d31
--- /dev/null
+++ b/gnu/packages/sagemath.scm
@@ -0,0 +1,60 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2019 Andreas Enge <andreas@enge.fr>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages sagemath)
+  #:use-module ((guix licenses) #:prefix license:)
+  #:use-module (guix packages)
+  #:use-module (guix download)
+  #:use-module (guix build-system python)
+  #:use-module (gnu packages algebra)
+  #:use-module (gnu packages multiprecision)
+  #:use-module (gnu packages python)
+  #:use-module (gnu packages python-xyz))
+
+
+(define-public python-cypari2
+ (package
+   (name "python-cypari2")
+   (version "2.0.3")
+   (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "cypari2" version))
+       (sha256
+         (base32
+           "0mghbmilmy34xp1d50xdx76sijqxmpkm2bcgx2v1mdji2ff7n0yc"))))
+   (build-system python-build-system)
+   (native-inputs
+     `(("python-cython" ,python-cython)))
+   (propagated-inputs
+     `(("python-cysignals" ,python-cysignals)))
+   (inputs
+     `(("gmp" ,gmp)
+       ("pari-gp", pari-gp)))
+   (home-page "https://cypari2.readthedocs.io/")
+   (synopsis
+     "Python interface to the number theory library libpari")
+   (description
+     "Cypari2 provides a Python interface to the number theory library
+PARI/GP.  It has been spun off from the SageMath mathematics software system,
+but it can be used independently.")
+   (license license:gpl2+)))
+
+(define-public python2-cypari2
+  (package-with-python2 python-cypari2))
+