summary refs log tree commit diff
path: root/gnu/packages/sagemath.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2019-11-16 09:34:27 +0100
committerMathieu Othacehe <m.othacehe@gmail.com>2019-11-16 09:34:27 +0100
commit154d97abdd16674fdebc763351f661bbcdc869a4 (patch)
tree0277a9380edd1390f16e432283d32499ffed36d1 /gnu/packages/sagemath.scm
parente4696c69d75f4fcf54c42beeb928032726bdaf7d (diff)
parent87e7faa2ae641d8302efc8b90f1e45f43f67f6da (diff)
downloadguix-154d97abdd16674fdebc763351f661bbcdc869a4.tar.gz
Merge remote-tracking branch master into core-updates
Diffstat (limited to 'gnu/packages/sagemath.scm')
-rw-r--r--gnu/packages/sagemath.scm12
1 files changed, 4 insertions, 8 deletions
diff --git a/gnu/packages/sagemath.scm b/gnu/packages/sagemath.scm
index 43da5c636a..a749f5633a 100644
--- a/gnu/packages/sagemath.scm
+++ b/gnu/packages/sagemath.scm
@@ -1,6 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2019 Andreas Enge <andreas@enge.fr>
 ;;; Copyright © 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
+;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -240,7 +241,7 @@ represented as strings.")
 (define-public pynac
   (package
     (name "pynac")
-    (version "0.7.25")
+    (version "0.7.26")
     (source
      (origin
        (method git-fetch)
@@ -249,8 +250,7 @@ represented as strings.")
               (commit (string-append "pynac-" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32
-         "0nnifvg6kzx0lq6gz7znind8g30v3d2pjfwgsdiks3vv9kv9nbj3"))))
+        (base32 "09d2p74x1arkydlxy6pw4p4byi7r8q7f29w373h4d8a215kadc6d"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("autoconf" ,autoconf)
@@ -404,11 +404,7 @@ used as internal storage type for polynomial structures.")
                   (string-append "INSTALL_DIR=" out))
                  ;; Sage renames the include directory, so we do it also.
                  (("include/Lfunction")
-                  "include/libLfunction")
-                 ;; Add --std=c++11 to be compatible with the "auto" keyword
-                 ;; introduced by lcalc-using-namespace-std.patch.
-                 (("^#EXTRA= -pg")
-                  "EXTRA=--std=c++11")))
+                  "include/libLfunction")))
              #t))
          (add-before 'install 'make-output-dirs
            (lambda* (#:key outputs #:allow-other-keys)