summary refs log tree commit diff
path: root/gnu/packages/samba.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-27 16:00:14 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-27 16:00:14 -0400
commitd0f0de4bf69da33037d2c9316edd7a58fa8afa96 (patch)
tree3fa0aa90eecb1142dd89ca94bf760133aa357043 /gnu/packages/samba.scm
parent990a4822f1cb45c1470fe38cbf17fd7bb54d0088 (diff)
parent5dc5d6fa8136f067c85295d88018a7cd8b7cfe40 (diff)
downloadguix-d0f0de4bf69da33037d2c9316edd7a58fa8afa96.tar.gz
Merge branch 'staging' into core-updates
Diffstat (limited to 'gnu/packages/samba.scm')
-rw-r--r--gnu/packages/samba.scm18
1 files changed, 17 insertions, 1 deletions
diff --git a/gnu/packages/samba.scm b/gnu/packages/samba.scm
index 0095d51e88..590f7c4668 100644
--- a/gnu/packages/samba.scm
+++ b/gnu/packages/samba.scm
@@ -293,6 +293,8 @@ Samba is an important component to seamlessly integrate Linux/Unix Servers and
 Desktops into Active Directory environments using the winbind daemon.")
     (license license:gpl3+)))
 
+;;; FIXME: Invert inheritance relationship; the "fixed" package shouldn't be
+;;; susceptible to changes in the free one.
 (define-public samba/fixed
   ;; Version that rarely changes, depended on by libsoup.
   (hidden-package
@@ -304,7 +306,21 @@ Desktops into Active Directory environments using the winbind daemon.")
         (uri (string-append "https://download.samba.org/pub/samba/stable/"
                             "samba-" version ".tar.gz"))
         (sha256
-         (base32 "0fl2y5avmyxjadh6zz0fwz35akd6c4j9lldzp2kyvjrgm36qx1h4")))))))
+         (base32 "1nrp85aya0pbbqdqjaqcw82cnzzys16yls37hi2h6mci8d09k4si"))))
+     (native-inputs
+      (list perl-parse-yapp
+            pkg-config
+            python-cryptography         ;for krb5 tests
+            python-dnspython
+            python-iso8601
+            python-markdown
+            rpcsvc-proto                ;for 'rpcgen'
+            python-pyasn1               ;for krb5 tests
+            ;; For generating man pages.
+            docbook-xml-4.2
+            docbook-xsl
+            libxslt
+            libxml2)))))
 
 (define-public talloc
   (package