summary refs log tree commit diff
path: root/gnu/packages/samba.scm
diff options
context:
space:
mode:
authorPierre Langlois <pierre.langlois@gmx.com>2020-09-19 23:57:41 +0100
committerPierre Langlois <pierre.langlois@gmx.com>2020-09-22 19:52:07 +0100
commitd3456739c5afd210cdc47b8c147adc277b84bfa8 (patch)
tree79ae437f1759ff625c084d1f149f479be0c69371 /gnu/packages/samba.scm
parenta2c0dbb84a5537a0f9edb67dd20af3c7fe773aea (diff)
downloadguix-d3456739c5afd210cdc47b8c147adc277b84bfa8.tar.gz
gnu: samba: Fix fcntl hint detection in configure script.
The configure script generates a C program to detect support for
lifetime hints on files.  But this program could crash, potentially
leaving a stale unreadable file behind which could cause the
patch-generated-file-shebang phase to fail.

Reported upstream <https://bugzilla.samba.org/show_bug.cgi?id=14503>.

* gnu/packages/patches/patches/samba-fix-fcntl-hint-detection.patch: New
file.
* gnu/packages/samba.scm (samba)[origin]: Add patch.
* gnu/local.mk (dist_patch_DATA): Register patch.
Diffstat (limited to 'gnu/packages/samba.scm')
-rw-r--r--gnu/packages/samba.scm2
1 files changed, 2 insertions, 0 deletions
diff --git a/gnu/packages/samba.scm b/gnu/packages/samba.scm
index c04426c49c..76a9c01866 100644
--- a/gnu/packages/samba.scm
+++ b/gnu/packages/samba.scm
@@ -32,6 +32,7 @@
   #:use-module (guix build-system gnu)
   #:use-module (guix licenses)
   #:use-module (guix utils)
+  #:use-module (gnu packages)
   #:use-module (gnu packages acl)
   #:use-module (gnu packages admin)
   #:use-module (gnu packages autotools)
@@ -182,6 +183,7 @@ external dependencies.")
                            "samba-" version ".tar.gz"))
        (sha256
         (base32 "1lkgih0vrarf5zy6chspkwarqdylzwr63nxr3qjkpazrs86nlm9h"))
+       (patches (search-patches "samba-fix-fcntl-hint-detection.patch"))
        (modules '((guix build utils)))
        (snippet
         '(begin