summary refs log tree commit diff
path: root/gnu/packages/samba.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-27 15:43:20 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-27 15:45:21 -0400
commit2e5d79aca239c10074032b19dfa08da6dab7bd20 (patch)
tree5e3e02adfdff38f29f701a338012095c037a0eef /gnu/packages/samba.scm
parent968ec0a87032b10f2a81597b6ede7a511e43631f (diff)
downloadguix-2e5d79aca239c10074032b19dfa08da6dab7bd20.tar.gz
gnu: samba/fixed: Do not inherit native-inputs.
* gnu/packages/samba.scm (samba/fixed): Add a FIXME comment.
[native-inputs]: Copy the complete native inputs from samba, to protect against
unintended changes in the inherited package.
Diffstat (limited to 'gnu/packages/samba.scm')
-rw-r--r--gnu/packages/samba.scm18
1 files changed, 17 insertions, 1 deletions
diff --git a/gnu/packages/samba.scm b/gnu/packages/samba.scm
index fdcd6ec991..739aeae369 100644
--- a/gnu/packages/samba.scm
+++ b/gnu/packages/samba.scm
@@ -290,6 +290,8 @@ Samba is an important component to seamlessly integrate Linux/Unix Servers and
 Desktops into Active Directory environments using the winbind daemon.")
     (license license:gpl3+)))
 
+;;; FIXME: Invert inheritance relationship; the "fixed" package shouldn't be
+;;; susceptible to changes in the free one.
 (define-public samba/fixed
   ;; Version that rarely changes, depended on by libsoup.
   (hidden-package
@@ -301,7 +303,21 @@ Desktops into Active Directory environments using the winbind daemon.")
         (uri (string-append "https://download.samba.org/pub/samba/stable/"
                             "samba-" version ".tar.gz"))
         (sha256
-         (base32 "1nrp85aya0pbbqdqjaqcw82cnzzys16yls37hi2h6mci8d09k4si")))))))
+         (base32 "1nrp85aya0pbbqdqjaqcw82cnzzys16yls37hi2h6mci8d09k4si"))))
+     (native-inputs
+      (list perl-parse-yapp
+            pkg-config
+            python-cryptography         ;for krb5 tests
+            python-dnspython
+            python-iso8601
+            python-markdown
+            rpcsvc-proto                ;for 'rpcgen'
+            python-pyasn1               ;for krb5 tests
+            ;; For generating man pages.
+            docbook-xml-4.2
+            docbook-xsl
+            libxslt
+            libxml2)))))
 
 (define-public talloc
   (package