summary refs log tree commit diff
path: root/gnu/packages/samba.scm
diff options
context:
space:
mode:
authorBenjamin <benjamin@uvy.fr>2023-11-07 17:36:16 +0100
committerLudovic Courtès <ludo@gnu.org>2023-11-25 23:35:01 +0100
commitc7ec42afe3ffd0312bd89f26775c58b0d1de2bd9 (patch)
treecbd3962eb4c18380aadf2d2c706a9cac9f4bfd45 /gnu/packages/samba.scm
parent625a847d2a554168bec6e294888d9d1f8ab03d08 (diff)
downloadguix-c7ec42afe3ffd0312bd89f26775c58b0d1de2bd9.tar.gz
gnu: Add ppp-2.4.9.
* gnu/packages/samba.scm (ppp-2.4.9): New variable.

Change-Id: I496016429ec4a8289b2a4ab51caa9245b914b4a5
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/samba.scm')
-rw-r--r--gnu/packages/samba.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/samba.scm b/gnu/packages/samba.scm
index 89a79cee2d..f52b86e1ed 100644
--- a/gnu/packages/samba.scm
+++ b/gnu/packages/samba.scm
@@ -507,6 +507,38 @@ and IPV6 and the protocols layered above them, such as TCP and UDP.")
                    license:gpl2+
                    license:public-domain))))
 
+(define-public ppp-2.4.9
+  (package
+    (inherit ppp)
+    (name "ppp")
+    (version "2.4.9")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/ppp-project/ppp")
+                    (commit (string-append "ppp-" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1bhhksdclsnkw54a517ndrw55q5zljjbh9pcqz1z4a2z2flxpsgk"))))
+         (arguments
+    (list #:tests? #f                    ;; No "check" target
+          #:make-flags #~(list (string-append "CC=" #$(cc-for-target)))
+          #:phases
+          #~(modify-phases %standard-phases
+              (add-before 'configure 'patch-Makefile
+                (lambda* (#:key inputs #:allow-other-keys)
+                  (let ((openssl (assoc-ref inputs "openssl"))
+                        (libpcap (assoc-ref inputs "libpcap")))
+                    (substitute* "pppd/Makefile.linux"
+                      (("/usr/include/openssl")
+                       (string-append openssl "/include"))
+                      (("-DPPP_FILTER")
+                       (string-append "-DPPP_FILTER -I" libpcap "/include")))
+                    (substitute* "pppd/pppcrypt.h"
+                      (("des\\.h") "openssl/des.h")))
+                  #t)))))))
+
 (define-public wsdd
   (package
     (name "wsdd")