summary refs log tree commit diff
path: root/gnu/packages/samba.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-06-12 19:51:23 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-12-06 15:58:18 +0100
commit3d53869e302540cb9a80cdcbbabea2b67200c0c5 (patch)
tree543b34d40f1db7ca7f304291d679564a4c55347b /gnu/packages/samba.scm
parent4a21d1765d8c158b3f1e9851f106cd8120f6caea (diff)
downloadguix-3d53869e302540cb9a80cdcbbabea2b67200c0c5.tar.gz
gnu: ldb: Fix build on 32-bit systems.
* gnu/packages/samba.scm (ldb)[inputs]: Only add LMDB on 64-bit systems.
[arguments]: Make #:tests? conditional on LMDB availability.
Diffstat (limited to 'gnu/packages/samba.scm')
-rw-r--r--gnu/packages/samba.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/samba.scm b/gnu/packages/samba.scm
index 66d0b5a35d..fd9bdd9724 100644
--- a/gnu/packages/samba.scm
+++ b/gnu/packages/samba.scm
@@ -365,7 +365,10 @@ many event types, including timers, signals, and the classic file descriptor eve
                   #t))))
     (build-system gnu-build-system)
     (arguments
-     '(#:phases
+     '(;; LMDB is only supported on 64-bit systems, yet the test suite
+       ;; requires it.
+       #:tests? (assoc-ref %build-inputs "lmdb")
+       #:phases
        (modify-phases %standard-phases
          (replace 'configure
            ;; ldb use a custom configuration script that runs waf.
@@ -385,7 +388,9 @@ many event types, including timers, signals, and the classic file descriptor eve
      `(("talloc" ,talloc)
        ("tdb" ,tdb)))
     (inputs
-     `(("lmdb" ,lmdb)
+     `(,@(if (target-64bit?)
+             `(("lmdb" ,lmdb))
+             '())
        ("popt" ,popt)
        ("tevent" ,tevent)))
     (synopsis "LDAP-like embedded database")