summary refs log tree commit diff
path: root/gnu/packages/samba.scm
diff options
context:
space:
mode:
authorRutger Helling <rhelling@mykolab.com>2019-03-20 20:23:34 +0100
committerRutger Helling <rhelling@mykolab.com>2019-03-20 20:25:51 +0100
commitbcf66fc2e75151b248265ed12ec8453fe9b0ce47 (patch)
treea387466c126e9087bc618964f4b20431bdf61710 /gnu/packages/samba.scm
parent14e6b6a0ae7c7fd648a11f9d00cc81f49241269e (diff)
downloadguix-bcf66fc2e75151b248265ed12ec8453fe9b0ce47.tar.gz
gnu: samba: Update to 4.10.0.
* gnu/packages/samba.scm (samba): Update to 4.10.0.
[native-inputs]: Replace python-2 with python.
Diffstat (limited to 'gnu/packages/samba.scm')
-rw-r--r--gnu/packages/samba.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/samba.scm b/gnu/packages/samba.scm
index d10c6ebc9c..c8b1dbe266 100644
--- a/gnu/packages/samba.scm
+++ b/gnu/packages/samba.scm
@@ -7,6 +7,7 @@
 ;;; Copyright © 2017, 2018 Marius Bakke <mbakke@fastmail.com>
 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2019 Rutger Helling <rhelling@mykolab.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -151,14 +152,14 @@ anywhere.")
 (define-public samba
   (package
     (name "samba")
-    (version "4.9.5")
+    (version "4.10.0")
     (source (origin
              (method url-fetch)
              (uri (string-append "https://download.samba.org/pub/samba/stable/"
                                  "samba-" version ".tar.gz"))
              (sha256
               (base32
-               "001p896z609vb0qs196bgl362j7y3qibgm5gcl9028lfv795d287"))))
+               "0n1ld77y8sydkpx6l8i2hqa1k7hpkr8df91pg849glc4b85407wz"))))
     (build-system gnu-build-system)
     (arguments
      `(#:phases
@@ -225,7 +226,7 @@ anywhere.")
        ("xsltproc" ,libxslt)           ;ditto
        ("perl" ,perl)
        ("pkg-config" ,pkg-config)
-       ("python" ,python-2))) ; incompatible with Python 3
+       ("python" ,python)))
     (home-page "https://www.samba.org/")
     (synopsis
      "The standard Windows interoperability suite of programs for GNU and Unix")