summary refs log tree commit diff
path: root/gnu/packages/samba.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-12-23 23:12:42 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-12-24 04:01:05 +0100
commitb0a46bcc0268770f7018d93936a7cfa8b0a25251 (patch)
tree5f692c68b77f8d6fe088db9634dbaa1f24f87983 /gnu/packages/samba.scm
parent88c9408070280db51d1a0e604b9ec77f1611ab3c (diff)
downloadguix-b0a46bcc0268770f7018d93936a7cfa8b0a25251.tar.gz
gnu: cifs-utils: Update to 6.10.
* gnu/packages/samba.scm (cifs-utils): Update to 6.10.
[arguments]: Force a ‘bootstrap’.
Add a ‘create-man8dir’ phase.
Diffstat (limited to 'gnu/packages/samba.scm')
-rw-r--r--gnu/packages/samba.scm18
1 files changed, 15 insertions, 3 deletions
diff --git a/gnu/packages/samba.scm b/gnu/packages/samba.scm
index a60b735414..ecfbdd1af0 100644
--- a/gnu/packages/samba.scm
+++ b/gnu/packages/samba.scm
@@ -58,14 +58,14 @@
 (define-public cifs-utils
   (package
     (name "cifs-utils")
-    (version "6.9")
+    (version "6.10")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "https://download.samba.org/pub/linux-cifs/"
                            "cifs-utils/cifs-utils-" version ".tar.bz2"))
        (sha256 (base32
-                "175cp509wn1zv8p8mv37hkf6sxiskrsxdnq22mhlsg61jazz3n0q"))))
+                "19q4b5bzlxhn1hpi843xrp6f50d33w7m0rs26krkg5h3x742kz4j"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("autoconf" ,autoconf)
@@ -81,12 +81,24 @@
     (arguments
      `(#:phases
        (modify-phases %standard-phases
+         (replace 'bootstrap
+           ;; Force a bootstrap to fix a ‘cannot find install-sh, install.sh,
+           ;; or shtool’ error since version 6.10.
+           (lambda _
+             (invoke "autoreconf" "-vfi")
+             #t))
          (add-before 'configure 'set-root-sbin
            (lambda _
              ;; Don't try to install into "/sbin".
              (setenv "ROOTSBINDIR"
                      (string-append (assoc-ref %outputs "out") "/sbin"))
-             #t)))))
+             #t))
+         (add-before 'install 'create-man8dir
+           ;; Create a directory that isn't created since version 6.10.
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let ((out (assoc-ref outputs "out")))
+               (mkdir-p (string-append out "/share/man/man8"))
+               #t))))))
     (synopsis "User-space utilities for Linux CIFS (Samba) mounts")
     (description "@code{cifs-utils} is a set of user-space utilities for
 mounting and managing @dfn{Common Internet File System} (CIFS) shares using