summary refs log tree commit diff
path: root/gnu/packages/samba.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-08-23 23:32:37 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-08-28 02:11:24 -0400
commit0c444ddd4d30568f49307185d3e08e7e961b4dda (patch)
treed964a23795dbeadd20f8c2ca05795c77fdb80f65 /gnu/packages/samba.scm
parenta4370f8d474fd140771968453b1760eca0569e89 (diff)
downloadguix-0c444ddd4d30568f49307185d3e08e7e961b4dda.tar.gz
gnu: samba: Update to 4.17.0rc3 to fix build.
* gnu/packages/samba.scm (samba): Update to 4.17.0rc3.
[source]: Adjust URL.
[configure-flags]: Delete leftover comment.
(samba/fixed): Update to 4.17.0rc3.
Diffstat (limited to 'gnu/packages/samba.scm')
-rw-r--r--gnu/packages/samba.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/samba.scm b/gnu/packages/samba.scm
index f6ead57cc1..9434455c19 100644
--- a/gnu/packages/samba.scm
+++ b/gnu/packages/samba.scm
@@ -185,14 +185,14 @@ external dependencies.")
 (define-public samba
   (package
     (name "samba")
-    (version "4.16.2")
+    (version "4.17.0rc3")             ;4.16.4 doesn't build with mit-krb5 1.20
     (source
      (origin
        (method url-fetch)
-       (uri (string-append "https://download.samba.org/pub/samba/stable/"
+       (uri (string-append "https://download.samba.org/pub/samba/rc/"
                            "samba-" version ".tar.gz"))
        (sha256
-        (base32 "1745gx36gyd7353a94w4lrgksbmms0502kj9gg63il9zbdns1dx0"))))
+        (base32 "1vi5vxv9cmy00wyrrr01xsdf4yc0fa96vj7980l51lnn90fgvj60"))))
     (build-system gnu-build-system)
     (arguments
      (list
@@ -226,7 +226,7 @@ external dependencies.")
                         ;; a single directory to avoid RPATH issues.
                         (string-append "--libdir=" libdir)
                         (string-append "--with-privatelibdir=" libdir)
-                        "--with-system-mitkrb5" ;#$(this-package-input "mit-krb5")
+                        "--with-system-mitkrb5"
                         (string-append "--with-system-mitkdc="
                                        (search-input-file inputs "sbin/krb5kdc"))
                         "--with-experimental-mit-ad-dc"))))
@@ -290,14 +290,14 @@ Desktops into Active Directory environments using the winbind daemon.")
   ;; Version that rarely changes, depended on by libsoup.
   (hidden-package
    (package/inherit samba
-     (version "4.15.3")
+     (version "4.17.0rc3")            ;4.16.4 doesn't build with mit-krb5 1.20
      (source
       (origin
         (method url-fetch)
-        (uri (string-append "https://download.samba.org/pub/samba/stable/"
+        (uri (string-append "https://download.samba.org/pub/samba/rc/"
                             "samba-" version ".tar.gz"))
         (sha256
-         (base32 "1nrp85aya0pbbqdqjaqcw82cnzzys16yls37hi2h6mci8d09k4si")))))))
+         (base32 "1vi5vxv9cmy00wyrrr01xsdf4yc0fa96vj7980l51lnn90fgvj60")))))))
 
 (define-public talloc
   (package