summary refs log tree commit diff
path: root/gnu/packages/sawfish.scm
diff options
context:
space:
mode:
authorFeng Shu <tumashu@163.com>2023-01-26 09:31:24 +0800
committer宋文武 <iyzsong@member.fsf.org>2023-01-28 14:36:49 +0800
commit09ffaaa43649b110722357ded8bc619b9a5448a8 (patch)
treea72860f3293efb03292990ad1d98e0878d163ab4 /gnu/packages/sawfish.scm
parent3a5937d240a03dd8aa7e550e45c4ee320d093ba9 (diff)
downloadguix-09ffaaa43649b110722357ded8bc619b9a5448a8.tar.gz
gnu: sawfish: Update to 1.13.0.
* gnu/packages/sawfish.scm (sawfish): Update to 1.13.0.
[arguments]: Use gexps.
[inputs]: Add gdk-pixbuf-xlib and gmp.

Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
Diffstat (limited to 'gnu/packages/sawfish.scm')
-rw-r--r--gnu/packages/sawfish.scm73
1 files changed, 37 insertions, 36 deletions
diff --git a/gnu/packages/sawfish.scm b/gnu/packages/sawfish.scm
index ab715b4a7d..1870a2950c 100644
--- a/gnu/packages/sawfish.scm
+++ b/gnu/packages/sawfish.scm
@@ -21,6 +21,7 @@
 
 (define-module (gnu packages sawfish)
   #:use-module ((guix licenses) #:select (gpl2+))
+  #:use-module (guix gexp)
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix build-system gnu)
@@ -113,14 +114,14 @@ backend of Sawfish.")
 (define-public sawfish
   (package
     (name "sawfish")
-    (version "1.12.0")
+    (version "1.13.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://download.tuxfamily.org/sawfish/"
                                   name "_" version ".tar.xz"))
               (sha256
                (base32
-                "1z7awzgw8d15aw17kpbj460pcxq8l2rhkaxk47w7yg9qrmg0xja4"))
+                "0pdgf9w5vrn3kfqxwggikj4yqg82rpy8ji613zdhidacz9dkqsw1"))
               (modules '((guix build utils)))
               (snippet
                '(begin
@@ -131,44 +132,44 @@ backend of Sawfish.")
                      "REP_DL_LOAD_PATH=$(REP_DL_LOAD_PATH):"))
                   (substitute* "src/Makefile.in"
                     ;; Install libraries for librep to $out/lib/rep.
-                    (("\\$\\(repexecdir\\)") "$(libdir)/rep"))
-                  #t))))
+                    (("\\$\\(repexecdir\\)") "$(libdir)/rep"))))))
     (build-system gnu-build-system)
     (arguments
-     '(#:tests? #f ; no tests
-       #:phases
-       (modify-phases %standard-phases
-         (add-before 'configure 'patch-exec-rep
-           (lambda _
-             (substitute* '("lisp/sawfish/cfg/main.jl.in"
-                            "scripts/sawfish-about.jl.in"
-                            "scripts/sawfish-client.jl"
-                            "scripts/sawfish-menu.jl")
-               (("exec rep") (string-append "exec " (which "rep"))))
-             #t))
-         (add-after 'install 'wrap-scripts
-           ;; Wrap scripts with REP_DL_LOAD_PATH for finding rep-gtk
-           ;; and sawfish.client.
-           (lambda* (#:key outputs #:allow-other-keys)
-             (define (wrap-script script)
-               (let ((out (assoc-ref outputs "out")))
-                 (wrap-program (string-append out script)
-                   `("REP_DL_LOAD_PATH" =
-                     ,(list (getenv "REP_DL_LOAD_PATH")
-                            (string-append out "/lib/rep"))))))
-             (for-each wrap-script
-                       (list "/bin/sawfish-about"
-                             "/bin/sawfish-client"
-                             "/bin/sawfish-config"
-                             "/lib/sawfish/sawfish-menu"))
-             #t)))))
+     (list
+      #:tests? #f ; no tests
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-before 'configure 'patch-exec-rep
+            (lambda _
+              (substitute* '("lisp/sawfish/cfg/main.jl.in"
+                             "scripts/sawfish-about.jl.in"
+                             "scripts/sawfish-client.jl"
+                             "scripts/sawfish-menu.jl")
+                (("exec rep") (string-append "exec " (which "rep"))))))
+          (add-after 'install 'wrap-scripts
+            ;; Wrap scripts with REP_DL_LOAD_PATH for finding rep-gtk
+            ;; and sawfish.client.
+            (lambda* (#:key outputs #:allow-other-keys)
+              (define (wrap-script script)
+                (let ((out (assoc-ref outputs "out")))
+                  (wrap-program (string-append out script)
+                    `("REP_DL_LOAD_PATH" =
+                      ,(list (getenv "REP_DL_LOAD_PATH")
+                             (string-append out "/lib/rep"))))))
+              (for-each wrap-script
+                        (list "/bin/sawfish-about"
+                              "/bin/sawfish-client"
+                              "/bin/sawfish-config"
+                              "/lib/sawfish/sawfish-menu")))))))
     (native-inputs
-     `(("gettext"     ,gettext-minimal)
-       ("makeinfo"    ,texinfo)
-       ("pkg-config"  ,pkg-config)
-       ("which"       ,which)))
+     (list gettext-minimal
+           texinfo
+           pkg-config
+           which))
     (inputs
-     (list libsm
+     (list gdk-pixbuf-xlib
+           gmp
+           libsm
            libxft
            libxinerama
            libxrandr