summary refs log tree commit diff
path: root/gnu/packages/scanner.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-02-15 15:54:39 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2021-02-15 17:23:55 +0100
commitcf9047b222934a3e4455cb1e1058d21c94b7214d (patch)
tree9b11e57e5f55714e8e137eb6b6575ddc9bda6533 /gnu/packages/scanner.scm
parent902d76c839e325cd452a71332b50a657df5f02c9 (diff)
downloadguix-cf9047b222934a3e4455cb1e1058d21c94b7214d.tar.gz
gnu: sane-backends-minimal: Remove obsolete #t return values.
* gnu/packages/scanner.scm (sane-backends-minimal)[source, arguments]:
Don't return #t from snippet or phases.
Diffstat (limited to 'gnu/packages/scanner.scm')
-rw-r--r--gnu/packages/scanner.scm12
1 files changed, 4 insertions, 8 deletions
diff --git a/gnu/packages/scanner.scm b/gnu/packages/scanner.scm
index 0db373eb04..08dd871bc2 100644
--- a/gnu/packages/scanner.scm
+++ b/gnu/packages/scanner.scm
@@ -59,8 +59,7 @@
               '(begin
                  (substitute* "tools/sane-desc.c"
                    (("asctime \\(localtime \\(&current_time\\)\\)")
-                    "\"1970-01-01\""))
-                 #t))))
+                    "\"1970-01-01\""))))))
     (build-system gnu-build-system)
     (native-inputs
      `(("autoconf" ,autoconf)
@@ -87,8 +86,7 @@
 
              ;; Disable tests that may require back ends to be built.
              (substitute* "testsuite/Makefile.in"
-               ((" backend ") " "))
-             #t))
+               ((" backend ") " "))))
          (add-before 'configure 'disable-failing-tests
            (lambda _
              ;; Disable unmaintained tests that that fail with errors resembling:
@@ -109,8 +107,7 @@
              ;; sanei_usb_test: sanei_usb_test.c:849: main: Assertion
              ;; `test_init (1)' failed.
              (substitute* "testsuite/sanei/Makefile.in"
-               (("sanei_usb_test\\$\\(EXEEXT\\) ") ""))
-             #t))
+               (("sanei_usb_test\\$\\(EXEEXT\\) ") ""))))
          (add-before 'build 'build-pixma_sane_options.c
            ;; "No rule to make target '../backend/pixma/pixma_sane_options.c',
            ;; needed by 'sane-backends.pot-update'."
@@ -123,8 +120,7 @@
                (copy-file "tools/udev/libsane.rules"
                           (string-append out
                                          "/lib/udev/rules.d/"
-                                         "60-libsane.rules"))
-               #t)))
+                                         "60-libsane.rules")))))
          (add-after 'install 'make-reproducible
            ;; XXX Work around an old bug <https://issues.guix.gnu.org/26247>.
            ;; Then work around "Throw to key `decoding-error' ..." by using sed.