summary refs log tree commit diff
path: root/gnu/packages/scheme.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2021-04-29 14:57:15 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2021-04-29 14:57:15 +0200
commit041d62f7cc244d7f6c0bd6d60cdf08e72d400313 (patch)
tree1b08bb8aea6fe5d55fcddb37f042c7f0734d1db7 /gnu/packages/scheme.scm
parent7540f6915c0ea04412ffdc8d70acd7b063251e74 (diff)
downloadguix-041d62f7cc244d7f6c0bd6d60cdf08e72d400313.tar.gz
gnu: bigloo: Update to 4.3g.
* gnu/packages/scheme.scm (bigloo): Update to 4.3g.
  [source]: Remove bundled libunistring and pcre.
  [arguments]: Add 'fix-gmp-detection' phase. Add options to 'configure' phase
  to throw an error when gmp is not found.
Diffstat (limited to 'gnu/packages/scheme.scm')
-rw-r--r--gnu/packages/scheme.scm16
1 files changed, 12 insertions, 4 deletions
diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index b5d526bfc3..5c2d2747b9 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -15,6 +15,7 @@
 ;;; Copyright © 2020 Brett Gilio <brettg@gnu.org>
 ;;; Copyright © 2020 Edouard Klein <edk@beaver-labs.com>
 ;;; Copyright © 2021 Philip McGrath <philip@philipmcgrath.com>
+;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -230,29 +231,34 @@ features an integrated Emacs-like editor and a large runtime library.")
 (define-public bigloo
   ;; Upstream modifies source tarballs in place, making significant changes
   ;; long after the initial publication: <https://bugs.gnu.org/33525>.
-  (let ((upstream-version "4.3f"))
+  (let ((upstream-version "4.3g"))
     (package
       (name "bigloo")
-      (version "4.3f")
+      (version "4.3g")
       (source (origin
                 (method url-fetch)
                 (uri (string-append "ftp://ftp-sop.inria.fr/indes/fp/Bigloo/bigloo"
                                     upstream-version ".tar.gz"))
                 (sha256
                  (base32
-                  "09whj8z91qbihk59dw2yb2ccbx9nk1c4l65j62pfs1pz822cpyh9"))
+                  "07305c134v7s1nz44igwsyqpb9qqia5zyng1q2qj60sskw3nbd67"))
                 ;; Remove bundled libraries.
                 (modules '((guix build utils)))
                 (snippet
                  '(begin
                     (for-each delete-file-recursively
-                              '("gc" "gmp" "libuv"))
+                              '("gc" "gmp" "libuv" "libunistring" "pcre"))
                     #t))))
       (build-system gnu-build-system)
       (arguments
        `(#:test-target "test"
          #:phases
          (modify-phases %standard-phases
+           (add-after 'unpack 'fix-gmp-detection
+             (lambda _
+               (substitute* "configure"
+                 (("gmpversion=`\\$autoconf gmp --lib=\\$gmplib`")
+                  "gmpversion=`\\$autoconf gmp --lib=\"\\$gmplib\"`"))))
            (replace 'configure
              (lambda* (#:key inputs outputs #:allow-other-keys)
 
@@ -275,6 +281,8 @@ features an integrated Emacs-like editor and a large runtime library.")
                          (string-append "--prefix=" out)
                                                   ; use system libraries
                          "--customgc=no"
+                         "--enable-gmp"
+                         "--customgmp=no"
                          "--customunistring=no"
                          "--customlibuv=no"
                          (string-append"--mv=" (which "mv"))