summary refs log tree commit diff
path: root/gnu/packages/scheme.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-10-28 01:14:34 +0100
committerLudovic Courtès <ludo@gnu.org>2014-10-28 01:18:50 +0100
commitf47638a3534c99fb8fef501c5827e9e32a6b4a2e (patch)
tree4611841beeff27a83c78b98f776fdcf1a574e789 /gnu/packages/scheme.scm
parent2d7bf949277a0889ced8aa486c4ef16cb7cf6b1a (diff)
downloadguix-f47638a3534c99fb8fef501c5827e9e32a6b4a2e.tar.gz
gnu: Mark a few packages as unsupported on MIPS.
* gnu/packages/gprolog.scm (gprolog): Add 'supported-systems' field.
* gnu/packages/qemu.scm (qemu-headless): Likewise.
* gnu/packages/qt.scm (qt): Likewise.
* gnu/packages/scheme.scm (racket): Likewise.
Diffstat (limited to 'gnu/packages/scheme.scm')
-rw-r--r--gnu/packages/scheme.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index 8e4f6ae3ec..40ea5b930c 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -422,4 +422,8 @@ implementation techniques and as an expository tool.")
 R6RS) and related languages, such as Typed Racket.  It features a compiler and
 a virtual machine with just-in-time native compilation, as well as a large set
 of libraries.")
-    (license lgpl2.0+)))
+    (license lgpl2.0+)
+
+    ;; Fails to build on MIPS with "address or size is not OS PAGE ALIGNED".
+    ;; See <http://hydra.gnu.org/build/121775>.
+    (supported-systems (delete "mips64el-linux" %supported-systems))))