summary refs log tree commit diff
path: root/gnu/packages/scheme.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-04-16 22:22:45 +0200
committerLudovic Courtès <ludo@gnu.org>2015-04-16 23:15:06 +0200
commitf0ad3c76973fbf1518eecac76eab0b657722a9ba (patch)
treed0c4d2631e033e47f338a37c44c86b1c4ad52aee /gnu/packages/scheme.scm
parent1a189da0e7c54e19484d2b79d505b860e436bd35 (diff)
downloadguix-f0ad3c76973fbf1518eecac76eab0b657722a9ba.tar.gz
gnu: bigloo: Add RUNPATH to the libraries.
* gnu/packages/scheme.scm (bigloo)[arguments]: Pass --ldflags
  'configure' flag.
Diffstat (limited to 'gnu/packages/scheme.scm')
-rw-r--r--gnu/packages/scheme.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index b450e33bbd..77d0d846c8 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -188,7 +188,10 @@ features an integrated Emacs-like editor and a large runtime library.")
                                ;; <http://article.gmane.org/gmane.lisp.scheme.bigloo/6126>.
                                ;; "--customgc=no" ; use our libgc
                                (string-append"--mv=" (which "mv"))
-                               (string-append "--rm=" (which "rm"))))))
+                               (string-append "--rm=" (which "rm"))
+                               (string-append "--ldflags=-Wl,-rpath="
+                                              (assoc-ref outputs "out")
+                                              "/lib/bigloo/" ,version)))))
                  (alist-cons-after
                   'install 'install-emacs-modes
                   (lambda* (#:key outputs #:allow-other-keys)