summary refs log tree commit diff
path: root/gnu/packages/scheme.scm
diff options
context:
space:
mode:
authorClément Lassieur <clement@lassieur.org>2017-05-30 08:56:34 +0200
committerClément Lassieur <clement@lassieur.org>2017-06-01 11:04:37 +0200
commit01d71f62224573ef2ab623a295f7e69656e9788f (patch)
treeddead7d496106435147652981e5b658fc590c07c /gnu/packages/scheme.scm
parent3e9afff873428f979b210aa41bb3f978b637449f (diff)
downloadguix-01d71f62224573ef2ab623a295f7e69656e9788f.tar.gz
gnu: sicp: Add the HTML version.
* gnu/packages/scheme.scm (sicp)[arguments]: Copy the HTML directory to the
output.
Diffstat (limited to 'gnu/packages/scheme.scm')
-rw-r--r--gnu/packages/scheme.scm3
1 files changed, 3 insertions, 0 deletions
diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index f6aee005c4..eacfd733db 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -7,6 +7,7 @@
 ;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
 ;;; Copyright © 2016, 2017 ng0 <contact.ng0@cryptolab.net>
 ;;; Copyright © 2017 John Darrington <jmd@gnu.org>
+;;; Copyright © 2017 Clément Lassieur <clement@lassieur.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -780,7 +781,9 @@ engineering.")
            (let ((gzip (assoc-ref %build-inputs "gzip"))
                  (source (assoc-ref %build-inputs "source"))
                  (texinfo (assoc-ref %build-inputs "texinfo"))
+                 (html-dir (string-append %output "/share/doc/" ,name "/html"))
                  (info-dir (string-append %output "/share/info")))
+             (copy-recursively (string-append source "/html") html-dir)
              (setenv "PATH" (string-append gzip "/bin"
                                            ":" texinfo "/bin"))
              (mkdir-p info-dir)