summary refs log tree commit diff
path: root/gnu/packages/sdcc.scm
diff options
context:
space:
mode:
authorSimon South <simon@simonsouth.net>2020-11-01 11:56:41 -0500
committerMarius Bakke <marius@gnu.org>2020-11-10 22:32:13 +0100
commit6f4c9ff6ec0fad24b6bd433a351613a3990aa561 (patch)
tree918d3a20655e28b4b7af5a0626f0d95d0a11245d /gnu/packages/sdcc.scm
parent4f4377f6dcdec45d8dd8aaa7b8c63454212abc7f (diff)
downloadguix-6f4c9ff6ec0fad24b6bd433a351613a3990aa561.tar.gz
gnu: sdcc: Remove non-free code.
* gnu/packages/sdcc.scm (sdcc)[source]: Add snippet to remove bundled non-free
source code.
Add patch to disable use of non-free code in build scripts and compiler and
update documentation to match.
* gnu/packages/patches/sdcc-disable-non-free-code.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.

Signed-off-by: Marius Bakke <marius@gnu.org>
Diffstat (limited to 'gnu/packages/sdcc.scm')
-rw-r--r--gnu/packages/sdcc.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/sdcc.scm b/gnu/packages/sdcc.scm
index 6d05470101..aad2cf9e62 100644
--- a/gnu/packages/sdcc.scm
+++ b/gnu/packages/sdcc.scm
@@ -18,6 +18,7 @@
 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
 
 (define-module (gnu packages sdcc)
+  #:use-module (gnu packages)
   #:use-module (gnu packages bison)
   #:use-module (gnu packages boost)
   #:use-module (gnu packages flex)
@@ -39,7 +40,14 @@
                     "/" version "/sdcc-src-" version ".tar.bz2"))
               (sha256
                (base32
-                "13llvx0j3v5qa7qd4fh7nix4j3alpd3ccprxvx163c4q8q4lfkc5"))))
+                "13llvx0j3v5qa7qd4fh7nix4j3alpd3ccprxvx163c4q8q4lfkc5"))
+              (modules '((guix build utils)))
+              (snippet
+               '(begin
+                  ;; Remove non-free source files
+                  (delete-file-recursively "device/non-free")
+                  #t))
+              (patches (search-patches "sdcc-disable-non-free-code.patch"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("bison" ,bison)