summary refs log tree commit diff
path: root/gnu/packages/search.scm
diff options
context:
space:
mode:
authorkiasoc5 <kiasoc5@disroot.org>2022-08-06 01:37:52 -0400
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-08-06 09:31:35 +0200
commit6665600e2354a76da1913d9847d47299e4a8f8dd (patch)
tree4f5498a126db02c20c0418b9496db7183b9e4fa4 /gnu/packages/search.scm
parent47989e0a5f02200c708f8b12e19c97c660ffcc4d (diff)
downloadguix-6665600e2354a76da1913d9847d47299e4a8f8dd.tar.gz
gnu: ugrep: Use G-Expressions.
* gnu/packages/search.scm (ugrep)[source]: Convert snippet to G-Expression.
[arguments]: Convert to list of G-Expressions.

Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'gnu/packages/search.scm')
-rw-r--r--gnu/packages/search.scm34
1 files changed, 17 insertions, 17 deletions
diff --git a/gnu/packages/search.scm b/gnu/packages/search.scm
index 4a867ec1be..025e862fa4 100644
--- a/gnu/packages/search.scm
+++ b/gnu/packages/search.scm
@@ -32,6 +32,7 @@
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix git-download)
+  #:use-module (guix gexp)
   #:use-module (guix utils)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system perl)
@@ -682,13 +683,11 @@ bibliographic data and simple document and bibtex retrieval.")
                (base32 "03b3lahc3zzsznaqnrk47f1cnd5jwakvwrkz0r4m2crk09cpfv57"))
               (file-name (git-file-name name version))
               (modules '((guix build utils)))
-              (snippet
-               '(begin
-                  (delete-file-recursively "bin") ; pre-built executables
-                  (for-each delete-file (find-files "tests" "^archive\\..*"))
-                  (for-each delete-file (find-files "tests" "^.*\\.pdf$"))
-                  (for-each delete-file (find-files "tests" "^.*\\.class$"))
-                  #t))))
+              (snippet #~(begin
+                           (delete-file-recursively "bin") ; pre-built executables
+                           (for-each delete-file (find-files "tests" "^archive\\..*"))
+                           (for-each delete-file (find-files "tests" "^.*\\.pdf$"))
+                           (for-each delete-file (find-files "tests" "^.*\\.class$"))))))
     (build-system gnu-build-system)
     (inputs
      (list bzip2
@@ -699,16 +698,17 @@ bibliographic data and simple document and bibtex retrieval.")
            zlib
            `(,zstd "lib")))
     (arguments
-     `(#:tests? #f                  ; no way to rebuild the binary input files
-       #:test-target "test"
-       #:phases
-       (modify-phases %standard-phases
-         (add-before 'check 'check-setup
-           (lambda _
-             ;; Unpatch shebangs in tests.
-             (substitute* '("tests/Hello.bat"
-                            "tests/Hello.sh")
-               (("#!/gnu/store/.*/bin/sh") "#!/bin/sh")))))))
+     (list
+      #:tests? #f                  ; no way to rebuild the binary input files
+      #:test-target "test"
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-before 'check 'check-setup
+            (lambda _
+              ;; Unpatch shebangs in tests.
+              (substitute* '("tests/Hello.bat"
+                             "tests/Hello.sh")
+                (("#!/gnu/store/.*/bin/sh") "#!/bin/sh")))))))
     (home-page "https://github.com/Genivia/ugrep/")
     (synopsis "Faster grep with an interactive query UI")
     (description "Ugrep is a ultra fast searcher of file systems, text