summary refs log tree commit diff
path: root/gnu/packages/search.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-11-05 19:45:01 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-11-05 23:46:38 +0100
commit208e82297cb5d67eea8fd9b1fbb06e9505b4607b (patch)
tree94f2739281f0c2e937675c7b305379aa2908abcf /gnu/packages/search.scm
parentd79c8148ccf4c28f99b62fb19234da58e16138c9 (diff)
downloadguix-208e82297cb5d67eea8fd9b1fbb06e9505b4607b.tar.gz
gnu: xapian: Update to 1.4.9.
* gnu/packages/patches/xapian-revert-5489fb2f8.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove it.
* gnu/packages/search.scm (xapian): Update to 1.4.9.
[source](patches): Remove.
(python-xapian-bindings): Update to 1.4.9.
Diffstat (limited to 'gnu/packages/search.scm')
-rw-r--r--gnu/packages/search.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/search.scm b/gnu/packages/search.scm
index 284771ab60..8237d51771 100644
--- a/gnu/packages/search.scm
+++ b/gnu/packages/search.scm
@@ -46,15 +46,14 @@
 (define-public xapian
   (package
     (name "xapian")
-    (version "1.4.7")
+    (version "1.4.9")
     ;; Note: When updating Xapian, remember to update xapian-bindings below.
     (source (origin
               (method url-fetch)
               (uri (string-append "https://oligarchy.co.uk/xapian/" version
                                   "/xapian-core-" version ".tar.xz"))
-              (patches (search-patches "xapian-revert-5489fb2f8.patch"))
               (sha256
-               (base32 "1lxmlds3v5s1gng9nk1rvmln1zcksrw5ds509y0glylwch5qmw0k"))))
+               (base32 "1k7m7m9jld96k16ansfw2w3c354pvd8ibhnrb6dw012g06fw7sfd"))))
     (build-system gnu-build-system)
     (inputs `(("zlib" ,zlib)
               ("util-linux" ,util-linux)))
@@ -92,7 +91,7 @@ rich set of boolean query operators.")
                                   "/xapian-bindings-" version ".tar.xz"))
               (sha256
                (base32
-                "0sjf9ck3a6p7xnd84w09l6s0xn2g03k9a9417f4mjnywfq9pa6a5"))))
+                "0ll3z3418r7bzxs4kyini2cbci5xl8i5scl3wyx88s2v4ak56bcz"))))
     (build-system gnu-build-system)
     (arguments
      `(#:configure-flags '("--with-python3")