summary refs log tree commit diff
path: root/gnu/packages/search.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2021-12-21 08:29:54 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-12-21 08:29:54 +0100
commit96d0d61a9b8a68001d7e50e89cf7b65eb24881ca (patch)
treee7b7ed1f06d609329a1e15f7cde928bc180fa554 /gnu/packages/search.scm
parent3eb90b03b415637913e877c3046fa2061f3b4043 (diff)
downloadguix-96d0d61a9b8a68001d7e50e89cf7b65eb24881ca.tar.gz
gnu: Add fsearch.
* gnu/packages/search.scm (fsearch): New variable.
Diffstat (limited to 'gnu/packages/search.scm')
-rw-r--r--gnu/packages/search.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/search.scm b/gnu/packages/search.scm
index 5d860fb756..178ff4e838 100644
--- a/gnu/packages/search.scm
+++ b/gnu/packages/search.scm
@@ -8,6 +8,7 @@
 ;;; Copyright © 2020 Hartmut Goebel <h.goebel@crazy-compilers.com>
 ;;; Copyright © 2021 Vinicius Monego <monego@posteo.net>
 ;;; Copyright © 2021 Alexandr Vityazev <avityazev@posteo.org>
+;;; Copyright © 2021 Nicolas Goaziou <mail@nicolasgoaziou.fr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -37,6 +38,7 @@
   #:use-module (guix build-system meson)
   #:use-module (gnu packages)
   #:use-module (gnu packages aspell)
+  #:use-module (gnu packages autotools)
   #:use-module (gnu packages base)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages check)
@@ -44,7 +46,11 @@
   #:use-module (gnu packages ebook)
   #:use-module (gnu packages freedesktop)
   #:use-module (gnu packages gawk)
+  #:use-module (gnu packages gettext)
+  #:use-module (gnu packages glib)
   #:use-module (gnu packages groff)
+  #:use-module (gnu packages gtk)
+  #:use-module (gnu packages icu4c)
   #:use-module (gnu packages less)
   #:use-module (gnu packages linux)
   #:use-module (gnu packages pcre)
@@ -290,6 +296,37 @@ accounting for new lines and paragraph changes.  It also has robust support
 for parsing HTML files.")
     (license gpl3+)))
 
+(define-public fsearch
+  (package
+    (name "fsearch")
+    (version "0.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/cboxdoerfer/fsearch")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1qscnrds5q6a6hcfx3apr9cvph7airvbivhgv82qci5dc8rm2jhz"))))
+    (build-system meson-build-system)
+    (native-inputs
+     (list autoconf
+           automake
+           gettext-minimal
+           `(,glib "bin")               ;for glib-compile-resources
+           intltool
+           libtool
+           pkg-config))
+    (inputs
+     (list gtk+ icu4c pcre))
+    (home-page "https://github.com/cboxdoerfer/fsearch")
+    (synopsis "Fast file search utility")
+    (description
+     "FSearch is a fast file search utility, inspired by Everything
+Search Engine.  It is written in C and based on GTK3.")
+    (license gpl2+)))
+
 (define-public recoll
   (package
     (name "recoll")