summary refs log tree commit diff
path: root/gnu/packages/serialization.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-11-28 21:40:13 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-12-04 20:10:34 +0100
commit936aa05209402dd399869ffae188db5dd5f67d69 (patch)
tree281017ffb73bf324c0921f8efe836fcbc2d68eba /gnu/packages/serialization.scm
parent208e743415d7c36e9684851a31cc30dec16db2c3 (diff)
downloadguix-936aa05209402dd399869ffae188db5dd5f67d69.tar.gz
gnu: Remove duplicate nlohmann-json-cpp package.
* gnu/packages/serialization.scm (nlohmann-json-cpp): Move variable ...
* gnu/packages/cpp.scm (nlohmann-json-cpp): ... here.  Mark as deprecated by
JSON-MODERN-CXX.
* gnu/packages/jupyter.scm (xeus)[inputs]: Change NLOHMANN-JSON-CPP to
JSON-MODERN-CXX.
* gnu/packages/video.scm (mkvtoolnix)[inputs]: Likewise.
Diffstat (limited to 'gnu/packages/serialization.scm')
-rw-r--r--gnu/packages/serialization.scm35
1 files changed, 1 insertions, 34 deletions
diff --git a/gnu/packages/serialization.scm b/gnu/packages/serialization.scm
index a213e4ba0c..8efad0af86 100644
--- a/gnu/packages/serialization.scm
+++ b/gnu/packages/serialization.scm
@@ -40,6 +40,7 @@
   #:use-module (gnu packages boost)
   #:use-module (gnu packages check)
   #:use-module (gnu packages compression)
+  #:use-module (gnu packages cpp)
   #:use-module (gnu packages databases)
   #:use-module (gnu packages documentation)
   #:use-module (gnu packages gcc)
@@ -378,40 +379,6 @@ convert JSON documents to BSON and the opposite.  BSON stands for Binary JSON,
 it is comparable to protobuf.")
     (license license:asl2.0)))
 
-(define-public nlohmann-json-cpp
-  (package
-    (name "nlohmann-json-cpp")
-    (version "3.7.0")
-    (source (origin
-              (method git-fetch)
-              (uri (git-reference
-                    (url "https://github.com/nlohmann/json.git")
-                    (commit (string-append "v" version))))
-              (file-name (git-file-name name version))
-              (sha256
-               (base32
-                "0v7xih4zjixxxfvkfbs7a8j9qcvpwlsv4vrkbyns3hc7b44nb8ap"))))
-    (build-system cmake-build-system)
-    (native-inputs
-     ;; Integer overflow tests like those from
-     ;; <https://github.com/nlohmann/json/issues/1447> fail when building with
-     ;; gcc@5.  Thus, build with a newer GCC.
-     `(("gcc" ,gcc-9)))
-    (arguments
-     '(#:phases (modify-phases %standard-phases
-                  (add-before 'build 'unset-path-variables
-                    (lambda _
-                      (unsetenv "C_INCLUDE_PATH")
-                      (unsetenv "CPLUS_INCLUDE_PATH")
-                      #t)))))
-    (home-page "https://nlohmann.github.io/json/")
-    (synopsis "JSON library for C++")
-    (description
-     "JSON library for C++ trying to accomplish “Intuitive syntax”,
-“Trivial integration”, and “Serious testing”.
-However, “Memory efficiency” and “Speed” have not been primary goals.")
-    (license license:expat)))
-
 (define-public python-ruamel.yaml
   (package
     (name "python-ruamel.yaml")