summary refs log tree commit diff
path: root/gnu/packages/serialization.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2018-02-21 12:25:17 -0500
committerLeo Famulari <leo@famulari.name>2018-03-15 10:57:53 -0400
commit8d4f34d6c9667c82f1dc136f54954fb4ccef81b1 (patch)
tree596b096e7dcbb06feca351d92158768ae4acea55 /gnu/packages/serialization.scm
parent5e5ac7102c2d28676ab1b756862ba9c02cd3ba2f (diff)
downloadguix-8d4f34d6c9667c82f1dc136f54954fb4ccef81b1.tar.gz
gnu: Add python-feather-format.
* gnu/packages/serialization.scm (python-feather-format,
python2-feather-format): New variables.
Diffstat (limited to 'gnu/packages/serialization.scm')
-rw-r--r--gnu/packages/serialization.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/serialization.scm b/gnu/packages/serialization.scm
index 0c07a6384c..3dd3a070e4 100644
--- a/gnu/packages/serialization.scm
+++ b/gnu/packages/serialization.scm
@@ -41,6 +41,7 @@
   #:use-module (gnu packages check)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages cran)
+  #:use-module (gnu packages databases)
   #:use-module (gnu packages documentation)
   #:use-module (gnu packages lua)
   #:use-module (gnu packages pkg-config)
@@ -462,3 +463,27 @@ game development and other performance-critical applications.")
     (description "Read and write feather files, a lightweight binary columnar
 daa store designed for maximum speed.")
     (license license:asl2.0)))
+
+(define-public python-feather-format
+  (package
+    (name "python-feather-format")
+    (version "0.4.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "feather-format" version))
+        (sha256
+         (base32
+          "1adivm5w5ji4qv7hq7942vqlk8l2wgw87bdlsia771z14z3zp857"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-pandas" ,python-pandas)
+       ("python-pyarrow" ,python-pyarrow)))
+    (home-page "https://github.com/wesm/feather")
+    (synopsis "Python wrapper to the Feather file format")
+    (description "This package provides a Python wrapper library to the
+Apache Arrow-based Feather binary columnar serialization data frame format.")
+    (license license:asl2.0)))
+
+(define-public python2-feather-format
+  (package-with-python2 python-feather-format))