summary refs log tree commit diff
path: root/gnu/packages/shells.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-12-11 01:00:02 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2022-12-11 01:00:01 +0100
commit55e2b9b0a41b7d5789379ce77e7734eef4e2bc45 (patch)
tree14f770afe3869df58929265fbe5e38b7b2ee5372 /gnu/packages/shells.scm
parent885903e2f62e9660a05919fecc70503fafefb4ed (diff)
downloadguix-55e2b9b0a41b7d5789379ce77e7734eef4e2bc45.tar.gz
gnu: dash: Update to 0.5.12.
* gnu/packages/shells.scm (dash): Update to 0.5.12.
[arguments]: Don't explicitly return #t from phases.
Diffstat (limited to 'gnu/packages/shells.scm')
-rw-r--r--gnu/packages/shells.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index b607060716..f40e491535 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -84,14 +84,14 @@
 (define-public dash
   (package
     (name "dash")
-    (version "0.5.11.5")
+    (version "0.5.12")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "http://gondor.apana.org.au/~herbert/dash/files/"
                            "dash-" version ".tar.gz"))
        (sha256
-        (base32 "1g93w4lpn3jfwn2gaq17a1lxdig11x0j7gr9byc3fy8zi4882xyv"))
+        (base32 "12pjm2j0q0q88nvqbcyqjwr8s1c29ilxyq2cdj8k42wbdv24liva"))
        (modules '((guix build utils)))
        (snippet
         '(begin
@@ -99,8 +99,7 @@
            ;; This isn't the case on Guix or indeed most other GNU systems.
            (substitute* "src/dash.1"
              (("the standard command interpreter for the system")
-              "a command interpreter based on the original Bourne shell"))
-           #t))))
+              "a command interpreter based on the original Bourne shell"))))))
     (build-system gnu-build-system)
     (inputs
      (list libedit))