summary refs log tree commit diff
path: root/gnu/packages/shells.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-07-27 17:53:05 +0200
committerMarius Bakke <marius@gnu.org>2022-07-27 17:53:05 +0200
commit6a3ed96af73939df69167b5736d03abf1d7ecebd (patch)
treec44435fc118e474835323ece38d5e560d0d62dc0 /gnu/packages/shells.scm
parentf7815e76b00f61959e3bae68e4d7365ace45abf1 (diff)
parent4059158e6a284976c80b0fe8f64f69868d59ab10 (diff)
downloadguix-6a3ed96af73939df69167b5736d03abf1d7ecebd.tar.gz
Merge branch 'staging' into core-updates
Diffstat (limited to 'gnu/packages/shells.scm')
-rw-r--r--gnu/packages/shells.scm15
1 files changed, 4 insertions, 11 deletions
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index 3d5e545536..1d28e6eb91 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -360,25 +360,18 @@ has a small feature set similar to a traditional Bourne shell.")
 (define-public es
   (package
     (name "es")
-    (version "0.9.1")
+    (version "0.9.2")
     (source
      (origin
-       (method url-fetch)
+       (method url-fetch/tarbomb)
        (uri (string-append "https://github.com/wryun/es-shell/releases/"
                            "download/v" version "/es-" version ".tar.gz"))
        (sha256
-        (base32
-         "1fplzxc6lncz2lv2fyr2ig23rgg5j96rm2bbl1rs28mik771zd5h"))
+        (base32 "1pgmqhsk14wyvl489sxdy7kdl2gwrsq1xvkip0z90kh888mlh9n9"))
        (file-name (string-append name "-" version ".tar.gz"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:test-target "test"
-       #:phases
-       (modify-phases %standard-phases
-         (add-before 'configure 're-enter-rootdir
-           ;; The tarball has no folder.
-           (lambda _
-             (chdir ".."))))))
+     (list #:test-target "test"))
     (inputs
      (list readline))
     (native-inputs