summary refs log tree commit diff
path: root/gnu/packages/shells.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-06-08 14:46:24 +0200
committerLudovic Courtès <ludo@gnu.org>2022-06-08 14:46:24 +0200
commit8c3e9da13a3c92a7db308db8c0d81cb474ad7799 (patch)
tree88d06952aa5cc3a9c4991d9c43eb7950ff174fe1 /gnu/packages/shells.scm
parent5439c04ebdb7b6405f5ea2446b375f1d155a8d95 (diff)
parent0c5299200ffcd16370f047b7ccb187c60f30da34 (diff)
downloadguix-8c3e9da13a3c92a7db308db8c0d81cb474ad7799.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/shells.scm')
-rw-r--r--gnu/packages/shells.scm45
1 files changed, 33 insertions, 12 deletions
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index f1676b0f7e..b7a1f4753e 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -18,7 +18,8 @@
 ;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2020, 2022 Marius Bakke <marius@gnu.org>
 ;;; Copyright © 2021, 2022 Nicolas Goaziou <mail@nicolasgoaziou.fr>
-;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
+;;; Copyright © 2021, 2022 Felix Gruber <felgru@posteo.net>
+;;; Copyright © 2022 Andrew Tropin <andrew@trop.in>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -64,6 +65,7 @@
   #:use-module (gnu packages tls)
   #:use-module (gnu packages version-control)
   #:use-module (gnu packages xorg)
+  #:use-module (gnu packages texinfo)
   #:use-module (guix build-system cargo)
   #:use-module (guix build-system cmake)
   #:use-module (guix build-system gnu)
@@ -521,9 +523,12 @@ history mechanism, job control and a C-like syntax.")
                        (substitute* "Test/A01grammar.ztst"
                          (("command -pv") "command -v")
                          (("command -p") "command ")
-                         (("'command' -p") "'command' "))
-                       #t)))))
-    (native-inputs (list autoconf))
+                         (("'command' -p") "'command' "))))
+                   (add-after 'build 'make-info
+                     (lambda _ (invoke "make" "info")))
+                   (add-after 'build 'install-info
+                     (lambda _ (invoke "make" "install.info"))))))
+    (native-inputs (list autoconf texinfo))
     (inputs (list ncurses pcre perl))
     (synopsis "Powerful shell for interactive use and scripting")
     (description "The Z shell (zsh) is a Unix shell that can be used
@@ -540,13 +545,13 @@ ksh, and tcsh.")
 (define-public xonsh
   (package
     (name "xonsh")
-    (version "0.9.27")
+    (version "0.12.4")
     (source
       (origin
         (method url-fetch)
         (uri (pypi-uri "xonsh" version))
         (sha256
-          (base32 "1maz7yvb5py91n699yqsna81x2i25mvrqkrcn7h7870nxd87ral2"))
+          (base32 "0xlac84nsgs0052n2pw8np1smlgghrbd7p6yrcp7d5qh8zdr9lx3"))
         (modules '((guix build utils)))
         (snippet
          `(begin
@@ -560,6 +565,7 @@ ksh, and tcsh.")
                                "xonsh/__amalgam__.py"
                                "xonsh/lexer.py"
                                "xonsh/parsers/base.py"
+                               "xonsh/parsers/completion_context.py"
                                "xonsh/xonfig.py")
               (("from xonsh\\.ply\\.(.*) import" _ module)
                (format #f "from ~a import" module))
@@ -567,10 +573,19 @@ ksh, and tcsh.")
             #t))))
     (build-system python-build-system)
     (arguments
-     '(;; TODO Try running run the test suite.
-       ;; See 'requirements-tests.txt' in the source distribution for more
-       ;; information.
-       #:tests? #f))
+     (list ;; TODO Try running run the test suite.
+           ;; See 'requirements-tests.txt' in the source distribution for more
+           ;; information.
+           #:tests? #f
+           #:phases
+           #~(modify-phases %standard-phases
+               (replace 'install
+                 (lambda* (#:key outputs #:allow-other-keys)
+                   (let* ((out (assoc-ref outputs "out")))
+                     (invoke "python" "-m" "compileall"
+                             "--invalidation-mode=unchecked-hash" out)
+                     (invoke "python" "setup.py" "install" "--root=/"
+                             (string-append "--prefix=" out))))))))
     (inputs
      (list python-ply))
     (home-page "https://xon.sh/")
@@ -834,14 +849,20 @@ Shell (pdksh).")
 (define-public oil
   (package
     (name "oil")
-    (version "0.9.7")
+    (version "0.9.9")
     (source
+     ;; oil's sources contain a modified version of CPython 2.7.13.
+     ;; According to https://www.oilshell.org/blog/2017/05/05.html
+     ;; this bundles version of CPython had certain unused parts removed
+     ;; and its build system has been replaced by a custom one.
+     ;; This would probably make it quite complicated to replace the
+     ;; bundled CPython with the one from the python2 package.
      (origin
        (method url-fetch)
        (uri (string-append "https://www.oilshell.org/download/oil-"
                            version ".tar.gz"))
        (sha256
-        (base32 "09ill1wks8gmixfc648wx25wx0wzlgkjj34bbpglx496i6yp81aw"))))
+        (base32 "1ymszq0wy7sy709yqx8dpmv7b37fkc57bdg02ah2gnjbvbk6s2z1"))))
     (build-system gnu-build-system)
     (arguments
      (list #:strip-binaries? #f         ; strip breaks the binary