summary refs log tree commit diff
path: root/gnu/packages/shells.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2018-04-26 15:05:19 -0400
committerLeo Famulari <leo@famulari.name>2018-04-26 15:06:03 -0400
commit379848ed31d995ed7ce38dd89bce7ea8679c13e7 (patch)
tree5e1ee0d507b81decbe648339289288b1e2224ee6 /gnu/packages/shells.scm
parent2690b6ce7da78eda4d936e3344fc6684a176ac81 (diff)
downloadguix-379848ed31d995ed7ce38dd89bce7ea8679c13e7.tar.gz
gnu: zsh: Update to 5.5.1.
* gnu/packages/shells.scm (zsh): Update to 5.5.1.
[source]: Remove obsolete patches.
* gnu/packages/patches/zsh-CVE-2018-7548.patch,
gnu/packages/patches/zsh-CVE-2018-7549.patch: Delete files.
* gnu/local.mk (dist_patch_DATA): Remove them.
Diffstat (limited to 'gnu/packages/shells.scm')
-rw-r--r--gnu/packages/shells.scm10
1 files changed, 4 insertions, 6 deletions
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index 8f3aa9b5f1..f0f25a0120 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -291,20 +291,18 @@ history mechanism, job control and a C-like syntax.")
 (define-public zsh
   (package
     (name "zsh")
-    (version "5.4.2")
+    (version "5.5.1")
     (source (origin
               (method url-fetch)
               (uri (list (string-append
                            "http://www.zsh.org/pub/zsh-" version
-                           ".tar.gz")
+                           ".tar.xz")
                          (string-append
                            "http://www.zsh.org/pub/old/zsh-" version
-                           ".tar.gz")))
-              (patches (search-patches "zsh-CVE-2018-7548.patch"
-                                       "zsh-CVE-2018-7549.patch"))
+                           ".tar.xz")))
               (sha256
                (base32
-                "1jdcfinzmki2w963msvsanv29vqqfmdfm4rncwpw0r3zqnrcsywm"))))
+                "105aqkdfsdxc4531anrj2zis2ywz6icagjam9lsc235yzh48ihz1"))))
     (build-system gnu-build-system)
     (arguments `(#:configure-flags '("--with-tcsetpgrp" "--enable-pcre")
                  #:phases