summary refs log tree commit diff
path: root/gnu/packages/shells.scm
diff options
context:
space:
mode:
authorng0 <ng0@n0.is>2018-01-14 17:25:31 +0000
committerLudovic Courtès <ludo@gnu.org>2018-01-16 16:00:20 +0100
commit2a5d663bfa519dd51fc4e3a6fafe5a3e4c2a18cf (patch)
treecf344e4d1a9bd9b5dde1e65affceba7cb658d9e8 /gnu/packages/shells.scm
parentb83fc85f9f40d9a5dff5b0d3ef38c1b93bd4c7e3 (diff)
downloadguix-2a5d663bfa519dd51fc4e3a6fafe5a3e4c2a18cf.tar.gz
gnu: fish-guix: Remove it.
fish-guix has been merged into Guix in 'etc/completion/fish'

* gnu/packages/shells.scm (fish-guix): Remove it.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/shells.scm')
-rw-r--r--gnu/packages/shells.scm28
1 files changed, 1 insertions, 27 deletions
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index 022287dbf5..e374c41b95 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -6,7 +6,7 @@
 ;;; Copyright © 2016, 2017 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2016 Stefan Reichör <stefan@xsteve.at>
 ;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
-;;; Copyright © 2017 ng0 <ng0@n0.is>
+;;; Copyright © 2017, 2018 ng0 <ng0@n0.is>
 ;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
 ;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
 ;;;
@@ -146,32 +146,6 @@ and syntax highlighting.")
     (home-page "https://fishshell.com/")
     (license gpl2)))
 
-(define-public fish-guix
-  (package
-    (name "fish-guix")
-    (version "0.1.2.1")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (string-append "https://d.n0.is/releases/fish-guix/"
-                           name "-" version ".tar.xz"))
-       (sha256
-        (base32
-         "0k71hcn7nr523w74jw2i68x52s9hv6vmasnvnn7yr3xxvzn4kqgf"))))
-    (build-system gnu-build-system)
-    (arguments
-     `(#:tests? #f ; No checks.
-       #:make-flags (list
-                     (string-append "PREFIX=" %output))
-       #:phases
-       (modify-phases %standard-phases
-         (delete 'configure)))) ; No configure script.
-    (home-page "https://n0.is/s/fish-guix/")
-    (synopsis "Fish completions for Guix")
-    (description
-     "Fish-guix provides completions for Guix for users of the fish shell.")
-    (license bsd-3)))
-
 (define-public rc
   (package
     (name "rc")