summary refs log tree commit diff
path: root/gnu/packages/shells.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2018-09-04 18:33:06 -0400
committerLeo Famulari <leo@famulari.name>2018-09-04 18:34:01 -0400
commitfcf4841c0ee16631e8330d797cf3788dac0eca05 (patch)
treeaa9a6646d76f1a237e914292a13e2541b2748157 /gnu/packages/shells.scm
parent95681e55862991a5303449a4eb3961441b337033 (diff)
downloadguix-fcf4841c0ee16631e8330d797cf3788dac0eca05.tar.gz
gnu: Zsh: Patch some tests that began failing in 5.6.
* gnu/packages/shells.scm (zsh)[arguments]: Patch the tests rather than deleting
them.
Diffstat (limited to 'gnu/packages/shells.scm')
-rw-r--r--gnu/packages/shells.scm18
1 files changed, 13 insertions, 5 deletions
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index c3647221aa..900c8ec686 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -336,11 +336,19 @@ history mechanism, job control and a C-like syntax.")
                          (("command -pv") "command -v")
                          (("command -p") "command ")
                          (("'command' -p") "'command' "))
-                       ;; Several of these tests fail spuriously in the Guix
-                       ;; build environment due to assumptions about PATH and
-                       ;; the location of the test files.  It was easier to just
-                       ;; skip them than try to make them work.
-                       (delete-file "Test/A05execution.ztst")
+                       ;; This file is ISO-8859-1 encoded.
+                       (with-fluids ((%default-port-encoding #f))
+                         (substitute* "Test/A05execution.ztst"
+                           ;; Help it find `sh`
+                           (("PATH=/bin:\\$\\{ZTST_testdir\\}/command.tmp/ tstcmd-slashless")
+                            (string-append "PATH=/bin:"
+                                           (assoc-ref %build-inputs "bash") "/bin:"
+                                           "${ZTST_testdir}/command.tmp/ tstcmd-slashless"))
+                           ;; Help it find `echo`
+                           (("PATH=/bin:\\$\\{ZTST_testdir\\}/command.tmp tstcmd-arg")
+                            (string-append "PATH=/bin:"
+                                           (assoc-ref %build-inputs "coreutils") "/bin:"
+                                           "PATH=/bin:${ZTST_testdir}/command.tmp tstcmd-arg"))))
                        #t)))))
     (native-inputs `(("autoconf" ,autoconf)))
     (inputs `(("ncurses" ,ncurses)