summary refs log tree commit diff
path: root/gnu/packages/shells.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-02-24 00:13:02 -0500
committerLeo Famulari <leo@famulari.name>2017-02-24 13:22:06 -0500
commit816417f5a48cbdf8e551b47d36bb56be17dd4b9e (patch)
treeeac23e177a0412a88a235e1177b108a1cc3bd437 /gnu/packages/shells.scm
parent83090f6ae7eb5353049b253f74670d72d9387463 (diff)
downloadguix-816417f5a48cbdf8e551b47d36bb56be17dd4b9e.tar.gz
gnu: tcsh: Update to 6.20.00.
* gnu/packages/shells.scm (tcsh): Update to 6.20.00.
[source]: Remove 'tcsh-do-not-define-BSDWAIT.patch'.
[inputs]: Remove coreutils. Move autoconf to ...
[native-inputs]: ... here. Add perl.
* gnu/packages/patches/tcsh-fix-autotest.patch: Adjust patch to upstream
changes.
* gnu/packages/patches/tcsh-do-not-define-BSDWAIT.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/shells.scm')
-rw-r--r--gnu/packages/shells.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index cc3968f9bf..d9e0f93a1a 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -218,7 +218,7 @@ written by Paul Haahr and Byron Rakitzis.")
 (define-public tcsh
   (package
     (name "tcsh")
-    (version "6.18.01")
+    (version "6.20.00")
     (source (origin
               (method url-fetch)
               ;; Old tarballs are moved to old/.
@@ -228,16 +228,16 @@ written by Paul Haahr and Byron Rakitzis.")
                                         "old/tcsh-" version ".tar.gz")))
               (sha256
                (base32
-                "1a4z9kwgx1iqqzvv64si34m60gj34p7lp6rrcrb59s7ka5wa476q"))
+                "17ggxkkn5skl0v1x0j6hbv5l0sgnidfzwv16992sqkdm983fg7dq"))
               (patches (search-patches "tcsh-fix-autotest.patch"
-                                       "tcsh-do-not-define-BSDWAIT.patch"
                                        "tcsh-fix-out-of-bounds-read.patch"))
               (patch-flags '("-p0"))))
     (build-system gnu-build-system)
-    (inputs
+    (native-inputs
      `(("autoconf" ,autoconf)
-       ("coreutils" ,coreutils)
-       ("ncurses" ,ncurses)))
+       ("perl" ,perl)))
+    (inputs
+     `(("ncurses" ,ncurses)))
     (arguments
      `(#:phases
        (alist-cons-before