summary refs log tree commit diff
path: root/gnu/packages/shellutils.scm
diff options
context:
space:
mode:
authorkiasoc5 <kiasoc5@disroot.org>2022-09-07 23:58:57 -0400
committerChristopher Baines <mail@cbaines.net>2022-09-12 14:22:50 +0100
commit9877fb03f0b1634d53d51c6777f6c4a73934360d (patch)
treed21b193aab4e6ccea30ea38bc43981fef4675b1f /gnu/packages/shellutils.scm
parent08199c69d4b3d20c9ea4ea56e69679d0df6fccf2 (diff)
downloadguix-9877fb03f0b1634d53d51c6777f6c4a73934360d.tar.gz
gnu: Add grml-zsh-config.
* gnu/packages/shellutils.scm (grml-zsh-config): New variable.

Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/shellutils.scm')
-rw-r--r--gnu/packages/shellutils.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/shellutils.scm b/gnu/packages/shellutils.scm
index 06860dc5b2..e70b9ef706 100644
--- a/gnu/packages/shellutils.scm
+++ b/gnu/packages/shellutils.scm
@@ -57,6 +57,7 @@
   #:use-module (gnu packages readline)
   #:use-module (gnu packages ruby)
   #:use-module (gnu packages shells)
+  #:use-module (gnu packages textutils)
   #:use-module (gnu packages tmux)
   #:use-module (gnu packages vim))
 
@@ -271,6 +272,38 @@ interactive terminal.  This helps in reviewing commands before running them,
 particularly in catching syntax errors.")
     (license license:bsd-3)))
 
+(define-public grml-zsh-config
+  (package
+    (name "grml-zsh-config")
+    (version "0.19.3")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://deb.grml.org/pool/main/g/grml-etc-core/grml-etc-core_"
+                    version ".tar.gz"))
+              (sha256
+               (base32
+                "05fri77028znjnvmh8mz3424rn8ilysj7hn8br2hk1qwkp4zzwp9"))))
+    (build-system copy-build-system)
+    (arguments
+     (list
+      #:phases
+      #~(modify-phases
+            %standard-phases
+          (add-before 'install 'make-doc
+            (lambda _ (with-directory-excursion "doc" (invoke "make")))))
+      #:install-plan
+      #~'(("etc/skel/.zshrc"  "etc/skel/.zshrc")
+          ("etc/zsh/keephack" "etc/zsh/keephack")
+          ("etc/zsh/zshrc"    "etc/zsh/zshrc")
+          ("doc/grmlzshrc.5"  "share/man/man5/grmlzshrc.5"))))
+    (native-inputs (list txt2tags))
+    (home-page "https://grml.org/zsh/")
+    (synopsis "Grml's zsh configuration")
+    (description "This package provides an interactive setup for zsh
+preconfigured by the Grml project.")
+    (license license:gpl2)))
+
 (define-public sh-z
   (package
     (name "sh-z")