summary refs log tree commit diff
path: root/gnu/packages/shellutils.scm
diff options
context:
space:
mode:
authorTimo Wilken <guix@twilken.net>2023-02-25 00:05:24 +0100
committerLudovic Courtès <ludo@gnu.org>2023-03-30 23:18:17 +0200
commite7558d16479158f893bca7c295986c08c151caa9 (patch)
tree5571bc3332c95c5461cad412a4b10702f1b6391c /gnu/packages/shellutils.scm
parent8c76eb61682a8c3347c739233c22c7bddb4027e8 (diff)
downloadguix-e7558d16479158f893bca7c295986c08c151caa9.tar.gz
gnu: Add zsh-completions
* gnu/packages/shellutils.scm (zsh-completions): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/shellutils.scm')
-rw-r--r--gnu/packages/shellutils.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/shellutils.scm b/gnu/packages/shellutils.scm
index e758340705..20d246be52 100644
--- a/gnu/packages/shellutils.scm
+++ b/gnu/packages/shellutils.scm
@@ -222,6 +222,32 @@ in Zsh intelligently.")
 as you type.")
     (license license:expat)))
 
+(define-public zsh-completions
+  (package
+    (name "zsh-completions")
+    (version "0.34.0")
+    (home-page "https://github.com/zsh-users/zsh-completions")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url home-page)
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0jjgvzj3v31yibjmq50s80s3sqi4d91yin45pvn3fpnihcrinam9"))))
+    (build-system copy-build-system)
+    (arguments
+     '(#:install-plan '(("src/" "share/zsh/site-functions/")
+                        ("README.md" "share/doc/zsh-completions/"))))
+    (synopsis "Additional completion definitions for Zsh")
+    (description
+     "This projects aims at gathering/developing new completion scripts that
+are not available in Zsh yet.  The scripts may be contributed to the Zsh
+project when stable enough.")
+    (license (license:non-copyleft "file://LICENSE"
+              "Custom BSD-like, permissive, non-copyleft license."))))
+
 (define-public zsh-history-substring-search
   (package
     (name "zsh-history-substring-search")