summary refs log tree commit diff
path: root/gnu/packages/skarnet.scm
diff options
context:
space:
mode:
authorEric Le Bihan <eric.le.bihan.dev@free.fr>2016-07-30 16:05:28 +0200
committerLudovic Courtès <ludo@gnu.org>2016-08-01 01:11:57 +0200
commit35977a8897db26a309df9afa487a52c09ecece29 (patch)
tree0e5d56c99fb7796bc67dacc8020451d7b7e1696c /gnu/packages/skarnet.scm
parent5e74529271fddb9dde88ac15f5ca26300d1cd0b2 (diff)
downloadguix-35977a8897db26a309df9afa487a52c09ecece29.tar.gz
gnu: Add s6-rc.
* gnu/packages/skarnet.scm (s6-rc): New variable.

Signed-off-by: Eric Le Bihan <eric.le.bihan.dev@free.fr>
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/skarnet.scm')
-rw-r--r--gnu/packages/skarnet.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/skarnet.scm b/gnu/packages/skarnet.scm
index 57fc12d1a3..1eda4461e1 100644
--- a/gnu/packages/skarnet.scm
+++ b/gnu/packages/skarnet.scm
@@ -204,3 +204,45 @@ as an alternative to the BIND, djbdns or other DNS clients.")))
 It includes command-line client and server management, TCP access control,
 privilege escalation across UNIX domain sockets, IDENT protocol management and
 clock synchronization.")))
+
+(define-public s6-rc
+  (package
+   (name "s6-rc")
+   (version "0.0.3.0")
+   (source
+    (origin
+     (method url-fetch)
+     (uri (string-append "http://skarnet.org/software/s6-rc/s6-rc-"
+                         version ".tar.gz"))
+     (sha256
+      (base32
+       "0bl94lbaphbpaaj4wbb86xqgp5bcgrf3m7p80mimw1qsjrvlxfay"))))
+    (build-system gnu-build-system)
+    (inputs `(("skalibs" ,skalibs)
+              ("execline" ,execline)
+              ("s6" ,s6)))
+    (arguments
+     '(#:configure-flags (list
+                          (string-append "--with-lib="
+                                         (assoc-ref %build-inputs "skalibs")
+                                         "/lib/skalibs")
+                          (string-append "--with-lib="
+                                         (assoc-ref %build-inputs "execline")
+                                         "/lib/execline")
+                          (string-append "--with-lib="
+                                         (assoc-ref %build-inputs "s6")
+                                         "/lib/s6")
+                          (string-append "--with-sysdeps="
+                                         (assoc-ref %build-inputs "skalibs")
+                                         "/lib/skalibs/sysdeps"))
+       #:tests? #f))
+    (home-page "http://skarnet.org/software/s6-rc")
+    (license isc)
+    (synopsis "Service manager for s6-based systems")
+    (description
+     "s6-rc is a service manager for s6-based systems, i.e. a suite of
+programs that can start and stop services, both long-running daemons and
+one-time initialization scripts, in the proper order according to a dependency
+tree.  It ensures that long-running daemons are supervised by the s6
+infrastructure, and that one-time scripts are also run in a controlled
+environment.")))